{"answers":{"affected":"2 open source packages ship an affected version, including librenms/librenms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84189 exists.","fix":"Upgrade librenms/librenms to 26.7.0 or later.","what":"CVE-2026-84189 is a critical cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-84189 and fix it if it is affected.\n\nWhat it is: CVE-2026-84189 is a critical cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84189 exists.\n\nAffected packages and fixed versions:\n- librenms/librenms (Packagist): affected all versions; fixed in 26.7.0\n- librenms/librenms (Packagist): affected all versions; fixed in 26.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84189/ (Markdown: https://insights.sbomify.com/CVE-2026-84189/index.md)","id":"CVE-2026-84189","markdown":"https://insights.sbomify.com/CVE-2026-84189/index.md","name":"CVE-2026-84189","record":{"aliases":["GHSA-7gww-x7fh-jf9j","GHSA-r436-6p4j-frwf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Network monitoring system","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into LibreNMS via Oxidized API responses, affecting all users viewing device configurations.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LibreNMS through 26.4.0 renders JSON fields (name, ip, model, author, commit message) returned by the admin-configurable Oxidized integration URL (oxidized.url) into the device showconfig page without applying htmlspecialchars(). An administrator who points the Oxidized URL at an attacker-controlled server (SSRF) can cause it to return malicious JSON, resulting in stored/persistent cross-site scripting affecting all users who view any device's showconfig tab. Fixed in 26.7.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"LibreNMS before 26.7.0 Stored XSS via Oxidized API","id":"CVE-2026-84189","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"LibreNMS before 26.5.0 Remote Code Execution via AboutController","id":"CVE-2026-84190"},"packages":[{"ecosystem":"Packagist","fixed":["26.7.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":null,"source":"GHSA-7gww-x7fh-jf9j"},{"ecosystem":"Packagist","fixed":["26.7.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":"pkg:composer/librenms/librenms","source":"GHSA-7gww-x7fh-jf9j"}],"prev":{"headline":"librenms before 26.7.0 Stored XSS via graph_descr settings","id":"CVE-2026-84188"},"products":["librenms"],"published":"2026-09-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["librenms"]},"summary":"Attackers can inject malicious scripts into LibreNMS via Oxidized API responses, affecting all users viewing device configurations.","url":"https://insights.sbomify.com/CVE-2026-84189/"}