{"answers":{"affected":"2 open source packages ship an affected version, including librenms/librenms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84190 exists.","fix":"Upgrade librenms/librenms to 26.5.0 or later.","what":"CVE-2026-84190 is a high-severity command injection vulnerability in librenms, published on 1 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-84190 and fix it if it is affected.\n\nWhat it is: CVE-2026-84190 is a high-severity command injection vulnerability in librenms, published on 1 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84190 exists.\n\nAffected packages and fixed versions:\n- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0\n- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84190/ (Markdown: https://insights.sbomify.com/CVE-2026-84190/index.md)","id":"CVE-2026-84190","markdown":"https://insights.sbomify.com/CVE-2026-84190/index.md","name":"CVE-2026-84190","record":{"aliases":["GHSA-jf24-8g2h-2wg7","GHSA-p7jp-qp65-h4xf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Network monitoring system","requires_auth":"low_privilege","summary":"An authenticated administrator can achieve remote code execution in LibreNMS by injecting commands into the snmpget configuration parameter.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"LibreNMS versions before 26.5.0 contain a remote code execution vulnerability in the AboutController where the snmpget configuration parameter is passed to shell_exec() without proper validation. An authenticated administrator can modify the snmpget configuration to point to a malicious executable file and trigger code execution by accessing the /about endpoint.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"LibreNMS before 26.5.0 Remote Code Execution via AboutController","id":"CVE-2026-84190","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"LibreNMS before 26.5.0 Stored XSS via SNMP VRF fields","id":"CVE-2026-84191"},"packages":[{"ecosystem":"Packagist","fixed":["26.5.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":null,"source":"GHSA-jf24-8g2h-2wg7"},{"ecosystem":"Packagist","fixed":["26.5.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":"pkg:composer/librenms/librenms","source":"GHSA-jf24-8g2h-2wg7"}],"prev":{"headline":"LibreNMS before 26.7.0 Stored XSS via Oxidized API","id":"CVE-2026-84189"},"products":["librenms"],"published":"2026-09-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["librenms"]},"summary":"An authenticated administrator can achieve remote code execution in LibreNMS by injecting commands into the snmpget configuration parameter.","url":"https://insights.sbomify.com/CVE-2026-84190/"}