# CVE-2026-84190: LibreNMS before 26.5.0 Remote Code Execution via AboutController

> An authenticated administrator can achieve remote code execution in LibreNMS by injecting commands into the snmpget configuration parameter.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-jf24-8g2h-2wg7, GHSA-p7jp-qp65-h4xf

## What is CVE-2026-84190?

CVE-2026-84190 is a high-severity command injection vulnerability in librenms, published on 1 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LibreNMS versions before 26.5.0 contain a remote code execution vulnerability in the AboutController where the snmpget configuration parameter is passed to shell_exec() without proper validation. An authenticated administrator can modify the snmpget configuration to point to a malicious executable file and trigger code execution by accessing the /about endpoint.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-84190?

2 open source packages ship an affected version, including librenms/librenms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 26.5.0 |
| `librenms/librenms` | Packagist | All versions | 26.5.0 |

## How do I fix CVE-2026-84190?

Upgrade librenms/librenms to 26.5.0 or later.

## Is CVE-2026-84190 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84190 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84190 and fix it if it is affected.

What it is: CVE-2026-84190 is a high-severity command injection vulnerability in librenms, published on 1 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84190 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0
- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84190/ (Markdown: https://insights.sbomify.com/CVE-2026-84190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84190
- OSV: https://osv.dev/vulnerability/CVE-2026-84190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84190/
Summaries are generated and may contain mistakes; the official description above is the record.
