{"answers":{"affected":"2 open source packages ship an affected version, including librenms/librenms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84192 exists.","fix":"Upgrade librenms/librenms to 26.5.0 or later.","what":"CVE-2026-84192 is a high-severity cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-84192 and fix it if it is affected.\n\nWhat it is: CVE-2026-84192 is a high-severity cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84192 exists.\n\nAffected packages and fixed versions:\n- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0\n- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84192/ (Markdown: https://insights.sbomify.com/CVE-2026-84192/index.md)","id":"CVE-2026-84192","markdown":"https://insights.sbomify.com/CVE-2026-84192/index.md","name":"CVE-2026-84192","record":{"aliases":["GHSA-7w8c-qgxg-m7jx","GHSA-r97f-5q78-rq8c"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Network monitoring system","requires_auth":"none","summary":"An attacker controlling a monitored device can inject JavaScript via SNMP or syslog data, leading to script execution in the web interface for authenticated users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LibreNMS before 26.3.1 contains a stored cross-site scripting vulnerability in legacy PHP templates that output SNMP-sourced and syslog-sourced data without escaping. An attacker who controls a monitored network device can inject arbitrary JavaScript through SNMP interface descriptions or syslog program fields that executes when authenticated users view affected pages.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"LibreNMS before 26.3.1 Stored XSS via SNMP/Syslog Data","id":"CVE-2026-84192","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"LibreNMS through 26.2.0 Stored Cross-Site Scripting via SNMP","id":"CVE-2026-84193"},"packages":[{"ecosystem":"Packagist","fixed":["26.5.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":null,"source":"GHSA-7w8c-qgxg-m7jx"},{"ecosystem":"Packagist","fixed":["26.5.0"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":"pkg:composer/librenms/librenms","source":"GHSA-7w8c-qgxg-m7jx"}],"prev":{"headline":"LibreNMS before 26.5.0 Stored XSS via SNMP VRF fields","id":"CVE-2026-84191"},"products":["librenms"],"published":"2026-09-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["librenms"]},"summary":"An attacker controlling a monitored device can inject JavaScript via SNMP or syslog data, leading to script execution in the web interface for authenticated users.","url":"https://insights.sbomify.com/CVE-2026-84192/"}