# CVE-2026-84192: LibreNMS before 26.3.1 Stored XSS via SNMP/Syslog Data

> An attacker controlling a monitored device can inject JavaScript via SNMP or syslog data, leading to script execution in the web interface for authenticated users.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-7w8c-qgxg-m7jx, GHSA-r97f-5q78-rq8c

## What is CVE-2026-84192?

CVE-2026-84192 is a high-severity cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LibreNMS before 26.3.1 contains a stored cross-site scripting vulnerability in legacy PHP templates that output SNMP-sourced and syslog-sourced data without escaping. An attacker who controls a monitored network device can inject arbitrary JavaScript through SNMP interface descriptions or syslog program fields that executes when authenticated users view affected pages.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-84192?

2 open source packages ship an affected version, including librenms/librenms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 26.5.0 |
| `librenms/librenms` | Packagist | All versions | 26.5.0 |

## How do I fix CVE-2026-84192?

Upgrade librenms/librenms to 26.5.0 or later.

## Is CVE-2026-84192 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84192 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84192 and fix it if it is affected.

What it is: CVE-2026-84192 is a high-severity cross-site scripting vulnerability in librenms, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84192 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0
- librenms/librenms (Packagist): affected all versions; fixed in 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84192/ (Markdown: https://insights.sbomify.com/CVE-2026-84192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84192
- OSV: https://osv.dev/vulnerability/CVE-2026-84192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84192/
Summaries are generated and may contain mistakes; the official description above is the record.
