# CVE-2026-84194: LibreNMS 23.10.0 before 26.4.0 OS Command Injection via Hostname

> Authenticated admins can execute arbitrary OS commands via crafted hostnames in LibreNMS when libvirt discovery is enabled.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** GHSA-jjvr-265m-qmq9, GHSA-wff2-9gjr-95f3

## What is CVE-2026-84194?

CVE-2026-84194 is a high-severity command injection vulnerability in librenms, published on 1 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LibreNMS versions >= 23.10.0 and < 26.2.0 (fixed in 26.4.0) contain an authenticated OS command injection vulnerability in libvirt discovery. When libvirt support is enabled (enable_libvirt=true), the device hostname ($this->getDevice()->hostname) is concatenated into shell commands (ssh, virsh list/dumpxml/domstate) in VminfoLibvirt.php and passed to exec() without escapeshellarg() or argument separation. An authenticated admin can set a crafted device hostname to inject arbitrary OS commands, leading to remote code execution in the discovery worker context.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-84194?


## How do I fix CVE-2026-84194?

No fix has been published for CVE-2026-84194 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-84194 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84194 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84194 and fix it if it is affected.

What it is: CVE-2026-84194 is a high-severity command injection vulnerability in librenms, published on 1 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84194 exists.

Affected product: librenms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84194/ (Markdown: https://insights.sbomify.com/CVE-2026-84194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84194
- OSV: https://osv.dev/vulnerability/CVE-2026-84194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84194/
Summaries are generated and may contain mistakes; the official description above is the record.
