{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84202 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-84202 is a high-severity unsafe deserialization vulnerability in modelscope, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-84202 and fix it if it is affected.\n\nWhat it is: CVE-2026-84202 is a high-severity unsafe deserialization vulnerability in modelscope, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84202 exists.\n\nAffected product: modelscope. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84202/ (Markdown: https://insights.sbomify.com/CVE-2026-84202/index.md)","id":"CVE-2026-84202","markdown":"https://insights.sbomify.com/CVE-2026-84202/index.md","name":"CVE-2026-84202","record":{"aliases":["GHSA-pq5m-26pg-cxxp","openSUSE-SU-2026:11736-1","openSUSE-SU-2026:11746-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ModelScope library","requires_auth":"none","summary":"Attackers can execute arbitrary code by crafting malicious model configuration files that exploit unsafe YAML deserialization in ModelScope.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"ModelScope uses PyYAML's unsafe yaml.Loader to parse model configuration files, allowing arbitrary code execution through Python object construction tags. Attackers can craft malicious model repositories with poisoned configuration files that execute code when loaded by users.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ModelScope through 1.40.0 Unsafe YAML Deserialization in Model Config Loading","id":"CVE-2026-84202","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"Memos 0.26.0 through 0.30.0 Insufficient Session Expiration on Password Change","id":"CVE-2026-84203"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.40.0-1.1"],"introduced":["0"],"last_affected":[],"package":"python-modelscope","purl":"pkg:rpm/opensuse/python-modelscope\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11736-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.4.2-1.1"],"introduced":["0"],"last_affected":[],"package":"python-modelscope-hub","purl":"pkg:rpm/opensuse/python-modelscope-hub\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11746-1"}],"prev":{"headline":"appium-mcp-server through 0.1.61 Path Traversal in write_file and write_files_batch","id":"CVE-2026-84201"},"products":["modelscope"],"published":"2026-09-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-01","vendors":["modelscope"]},"summary":"Attackers can execute arbitrary code by crafting malicious model configuration files that exploit unsafe YAML deserialization in ModelScope.","url":"https://insights.sbomify.com/CVE-2026-84202/"}