{"answers":{"affected":"2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-8421 in the wild and no public exploit code.","fix":"Upgrade concrete5/concrete5 to 9.5.1 or later.","what":"CVE-2026-8421 is a high-severity vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-8421 and fix it if it is affected.\n\nWhat it is: CVE-2026-8421 is a high-severity vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-8421 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-8421/ (Markdown: https://insights.sbomify.com/CVE-2026-8421/index.md)","id":"CVE-2026-8421","markdown":"https://insights.sbomify.com/CVE-2026-8421/index.md","name":"CVE-2026-8421","record":{"aliases":["GHSA-4c8m-6fwx-m7xq"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Concrete CMS","requires_auth":"none","summary":"Attackers can force admin package installation via CSRF, leading to remote code execution if package installation permissions are enabled.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"ConcreteCMS","cpe":[{"product":"concrete_cms","vendor":"concretecms"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Concrete CMS 9.5.0 and below contains a CSRF vulnerability in the install_package() method of concrete/controllers/single_page/dashboard/extend/install.php.  An attacker who can cause an authenticated administrator to visit a crafted page,  and who has placed or caused a package to be present under DIR_PACKAGES/\u003chandle\u003e/, can force the installation of that package without any CSRF protection. Package installation executes the package controller's install() method as the web server user, enabling remote code execution.  In order to be vulnerable, the victim must be passing canInstallPackages. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks  https://github.com/maru1009  for reporting.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Concrete CMS 9.5.0 and below is vulnerable to CSRF on install_package() with conditional token bypass leading to RCE","id":"CVE-2026-8421","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"concretecms:concrete_cms","products":["concretecms:concrete_cms"],"type":"csrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Remove meta boxes per user role \u003c= 1.01 - Cross-Site Request Forgery to Settings Update","id":"CVE-2026-8422"},"packages":[{"ecosystem":"Packagist","fixed":["9.5.1"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-4c8m-6fwx-m7xq"},{"ecosystem":"Packagist","fixed":["9.5.1"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-4c8m-6fwx-m7xq"}],"prev":{"headline":"BLOGCHAT Chat System \u003c= 1.3.6.3 - Cross-Site Request Forgery to Stored Cross-Site Scripting via Settings Update","id":"CVE-2026-8420"},"products":["Concrete CMS"],"published":"2026-05-21","related":[{"cvss_score":9.8,"headline":"Concrete CMS allows unauthorized access because directories can be created with insecure permissions","id":"CVE-2023-48648","kev_date_added":null,"published":"2023-11-17"},{"cvss_score":9.8,"headline":"Code injection in concrete CMS","id":"CVE-2022-21829","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.8,"headline":"Server-Side Request Forgery vulnerability in concrete5","id":"CVE-2021-22958","kev_date_added":null,"published":"2021-10-07"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2021-40098","kev_date_added":null,"published":"2021-09-27"},{"cvss_score":9.4,"headline":"Concrete CMS Vulnerable to Relative Path Traversal","id":"CVE-2026-8134","kev_date_added":null,"published":"2026-05-21"},{"cvss_score":9.1,"headline":"Path traversal in Concrete CMS","id":"CVE-2022-30117","kev_date_added":null,"published":"2022-06-24"},{"cvss_score":9.1,"headline":"Deserialization in n/a","id":"CVE-2021-40102","kev_date_added":null,"published":"2021-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-22","vendors":["Concrete CMS"]},"summary":"Attackers can force admin package installation via CSRF, leading to remote code execution if package installation permissions are enabled.","url":"https://insights.sbomify.com/CVE-2026-8421/"}