# CVE-2026-84292: fast-uri vulnerable to authority injection via an unvalidated port in serialize

> Attackers can inject authority delimiters via unvalidated port values in fast-uri, redirecting requests to attacker-controlled hosts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 3 Sep 2026
- **Also known as:** CLEANSTART-2026-CC59685, CLEANSTART-2026-QL19617, CLEANSTART-2026-RF54758, CLSA-2026-1790759588, CLSA-2026-1791833496, CLSA-2026-1791833719, CLSA-2026-1791833943, DEBIAN-CVE-2026-84292, ECHO-9a40-7285-682c, GHSA-qw65-cvwx-89v3, MINI-29hq-v2wh-cw7h, MINI-2g6m-6gg3-gwm5, MINI-362g-jm3x-gv28, MINI-66h8-m4vp-xqf2, MINI-6frv-5678-j7g9, MINI-6q3h-xf2x-f2xj, MINI-74wr-pcx7-j2j4, MINI-799x-wxhg-pm42, MINI-79wg-7fcg-5ffj, MINI-7gcw-cfc7-5g58, MINI-7vrh-j262-wpwc, MINI-8rv4-8wcp-9527, MINI-92ch-p2v3-c4cv, MINI-954v-7chw-rvjq, MINI-984g-mmxc-6pqq, MINI-9w83-42gx-7v6c, MINI-c7cm-8vw7-h9rj, MINI-cvj5-4pgh-qq8x, MINI-f5mm-wh2m-p9c3, MINI-fhc8-mw3r-vqpp, MINI-fw52-frhj-86p5, MINI-h3v6-h9w6-hm9m, MINI-h72x-p364-8m8c, MINI-mfrj-v4hw-g93r, MINI-mgcc-jfr5-hx6h, MINI-q3x5-m2wc-g2j9, MINI-qq8p-xjv7-xf2c, MINI-r2g4-93rc-282c, MINI-rfmr-93c8-wx35, MINI-vx96-xxp6-8339, MINI-x2w9-h5v3-5m9g, MINI-xc39-w9p3-hvgc, MINI-xg5w-mv5c-rrcj, MINI-xjp7-6gmx-f54r, MINI-xmv3-q2gm-f6q5, ROOT-APP-NPM-CVE-2026-84292, UBUNTU-CVE-2026-84292

## What is CVE-2026-84292?

CVE-2026-84292 is a high-severity vulnerability in fast-uri, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri serializes the port component of a URI without validating it. When recomposing the authority, the userinfo and host components are escaped but the port is concatenated verbatim, so a port value that is not a sequence of digits can inject authority delimiters, demoting the intended host to userinfo and pointing the authority at an attacker-controlled host. Both fast-uri and Node's URL read the result back as the attacker's host with no error, so re-validating the built URI does not catch it. This affects applications that build URIs from parts and assign untrusted data to the port component through the serialize, normalize, or equal functions in their object forms. The issue affects fast-uri versions before 2.4.6, from 3.0.0 before 3.1.7, and from 4.0.0 before 4.1.4. It is fixed in 2.4.6, 3.1.7, and 4.1.4, where recomposeAuthority rejects any port that is not a digit sequence per RFC 3986.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-84292?

6 open source packages ship an affected version, including fast-uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | All versions | 2.4.6 |
| `fast-uri` | npm | All versions | 2.4.6 |
| `fast-uri` | npm | From 3.0.0 | 3.1.7 |
| `fast-uri` | npm | From 3.0.0 | 3.1.7 |
| `fast-uri` | npm | From 4.0.0 | 4.1.4 |
| `fast-uri` | npm | From 4.0.0 | 4.1.4 |

Products: Openjsf Fast-Uri.

## How do I fix CVE-2026-84292?

Upgrade fast-uri to a fixed version for your release line: 2.4.6, 3.1.7 or 4.1.4.

## Is CVE-2026-84292 being exploited?

There is no known exploitation of CVE-2026-84292 in the wild and no public exploit code.

## Other vulnerabilities in fast-uri

- [CVE-2026-84394](https://insights.sbomify.com/CVE-2026-84394/): fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority (high 7.5)
- [CVE-2026-75899](https://insights.sbomify.com/CVE-2026-75899/): fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding (high 7.5)
- [CVE-2026-75931](https://insights.sbomify.com/CVE-2026-75931/): fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references (high 7.5)
- [CVE-2026-75975](https://insights.sbomify.com/CVE-2026-75975/): fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization (high 7.5)
- [CVE-2026-76172](https://insights.sbomify.com/CVE-2026-76172/): fast-uri vulnerable to host confusion via percent-encoded scheme normalization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84292 and fix it if it is affected.

What it is: CVE-2026-84292 is a high-severity vulnerability in fast-uri, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84292 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected all versions; fixed in 2.4.6
- fast-uri (npm): affected all versions; fixed in 2.4.6
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.7
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.7
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.4
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84292/ (Markdown: https://insights.sbomify.com/CVE-2026-84292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84292
- OSV: https://osv.dev/vulnerability/CVE-2026-84292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84292/
Summaries are generated and may contain mistakes; the official description above is the record.
