# CVE-2026-84302: Discourse: Non-participant moderators can read, edit, and delete PM content through Discourse AI reviewables

> Non-participant moderators can read, edit, and delete private message content via Discourse AI reviewables due to missing visibility checks.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** BIT-discourse-2026-84302, GHSA-3rx9-fqgh-wfpc

## What is CVE-2026-84302?

CVE-2026-84302 is a medium-severity missing authorization vulnerability in discourse, published on 24 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, Discourse AI reviewables associated with private messages could appear in the moderator review queue of a moderator who was not a participant in the message. Reviewable visibility filtering did not restrict private-message reviewables to the audience permitted to access the underlying private-message topic, allowing the moderator to read otherwise confidential content. Depending on the available reviewable action, the moderator could also modify the private message by closing its topic or deleting a post. Exploitation requires an authenticated moderator account and a pre-existing Discourse AI reviewable associated with a private message. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-84302?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.7.0 |

## How do I fix CVE-2026-84302?

Upgrade discourse to 2026.7.0 or later.

## Is CVE-2026-84302 being exploited?

There is no known exploitation of CVE-2026-84302 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84302 and fix it if it is affected.

What it is: CVE-2026-84302 is a medium-severity missing authorization vulnerability in discourse, published on 24 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-84302 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84302/ (Markdown: https://insights.sbomify.com/CVE-2026-84302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84302
- OSV: https://osv.dev/vulnerability/CVE-2026-84302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84302/
Summaries are generated and may contain mistakes; the official description above is the record.
