# CVE-2026-84310: pypdf: Possible long runtimes/large memory usage when retrieving outlines

> An attacker can cause excessive memory usage and long runtimes in pypdf by crafting a PDF with deeply nested outlines, leading to denial of service.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-84310, ECHO-54f4-f18d-f7cb, GHSA-23w6-3w8w-8484, MINI-3cjp-fj4h-24fp, MINI-548f-76c8-8cc2, MINI-5g47-f9jw-6vxf, MINI-8gv4-86v3-p4h7, MINI-8j6v-54fr-g884, MINI-94jq-7vfx-hvqm, MINI-c5q7-cr52-mhh8, MINI-fhg3-6c2x-mx82, MINI-q5jv-g288-8f79, MINI-rhvq-rc4c-5j85, MINI-v6fj-5w86-cj75, PYSEC-2026-3910, UBUNTU-CVE-2026-84310

## What is CVE-2026-84310?

CVE-2026-84310 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 1 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to 6.16.1, an attacker can craft a PDF that causes pypdf/_doc_common.py _get_outline to consume long runtimes and large amounts of memory when retrieving document outlines with large numbers of entries or deeply nested reused paths because the traversal lacked global entry-count and nesting-depth limits. This issue is fixed in version 6.16.1.

Weakness: CWE-834 (Excessive Iteration), CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2026-84310?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.16.1 |
| `pypdf` | PyPI | All versions | 6.16.1 |
| `pypdf` | PyPI | All versions | 6.16.1 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-84310?

Upgrade pypdf to 6.16.1 or later.

## Is CVE-2026-84310 being exploited?

There is no known exploitation of CVE-2026-84310 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84310 and fix it if it is affected.

What it is: CVE-2026-84310 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 1 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-84310 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.16.1
- pypdf (PyPI): affected all versions; fixed in 6.16.1
- pypdf (PyPI): affected all versions; fixed in 6.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84310/ (Markdown: https://insights.sbomify.com/CVE-2026-84310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84310
- OSV: https://osv.dev/vulnerability/CVE-2026-84310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84310/
Summaries are generated and may contain mistakes; the official description above is the record.
