{"answers":{"affected":"3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84313 exists.","fix":"Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.","what":"CVE-2026-84313 is a high-severity authentication bypass vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-84313 and fix it if it is affected.\n\nWhat it is: CVE-2026-84313 is a high-severity authentication bypass vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84313 exists.\n\nAffected packages and fixed versions:\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; no fix listed\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84313/ (Markdown: https://insights.sbomify.com/CVE-2026-84313/index.md)","id":"CVE-2026-84313","markdown":"https://insights.sbomify.com/CVE-2026-84313/index.md","name":"CVE-2026-84313","record":{"aliases":["GHSA-gfrc-g87h-7h5w","GO-2026-6786"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Nginx web UI","requires_auth":"low_privilege","summary":"Attackers with stolen JWTs can enroll TOTP or passkeys without re-authentication, enabling persistent account takeover in Nginx UI.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, POST /api/otp_enroll and POST /api/finish_passkey_register are registered outside RequireSecureSession and accept a normal authenticated session without verifying the current password. An attacker with a stolen JWT can bind an attacker-controlled TOTP secret when the victim has not already enabled TOTP, or can register an attacker-controlled passkey because that path has no equivalent existing-enrollment guard. These changes create persistent account access that can survive a password change and interfere with the legitimate user's authentication. This issue is fixed in version 2.4.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Nginx UI: TOTP / passkey enrolment requires no re-authentication, enabling persistent account takeover","id":"CVE-2026-84313","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint","id":"CVE-2026-84314"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":"pkg:golang/github.com/0xJacky/Nginx-UI","source":"GO-2026-6786"},{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":null,"source":"GHSA-gfrc-g87h-7h5w"},{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":"pkg:golang/github.com/0xJacky/Nginx-UI","source":"GHSA-gfrc-g87h-7h5w"}],"prev":{"headline":"Nginx UI: Casdoor SSO callback uses a constant `state` parameter (login CSRF)","id":"CVE-2026-84312"},"products":["nginx-ui"],"published":"2026-10-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["0xJacky"]},"summary":"Attackers with stolen JWTs can enroll TOTP or passkeys without re-authentication, enabling persistent account takeover in Nginx UI.","url":"https://insights.sbomify.com/CVE-2026-84313/"}