# CVE-2026-84313: Nginx UI: TOTP / passkey enrolment requires no re-authentication, enabling persistent account takeover

> Attackers with stolen JWTs can enroll TOTP or passkeys without re-authentication, enabling persistent account takeover in Nginx UI.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-gfrc-g87h-7h5w, GO-2026-6786

## What is CVE-2026-84313?

CVE-2026-84313 is a high-severity authentication bypass vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, POST /api/otp_enroll and POST /api/finish_passkey_register are registered outside RequireSecureSession and accept a normal authenticated session without verifying the current password. An attacker with a stolen JWT can bind an attacker-controlled TOTP secret when the victim has not already enabled TOTP, or can register an attacker-controlled passkey because that path has no equivalent existing-enrollment guard. These changes create persistent account access that can survive a password change and interfere with the legitimate user's authentication. This issue is fixed in version 2.4.1.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-84313?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | None |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |

## How do I fix CVE-2026-84313?

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.

## Is CVE-2026-84313 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84313 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84313 and fix it if it is affected.

What it is: CVE-2026-84313 is a high-severity authentication bypass vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84313 exists.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; no fix listed
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84313/ (Markdown: https://insights.sbomify.com/CVE-2026-84313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84313
- OSV: https://osv.dev/vulnerability/CVE-2026-84313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84313/
Summaries are generated and may contain mistakes; the official description above is the record.
