{"answers":{"affected":"3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84314 exists.","fix":"Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.","what":"CVE-2026-84314 is a high-severity missing authorization vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-84314 and fix it if it is affected.\n\nWhat it is: CVE-2026-84314 is a high-severity missing authorization vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84314 exists.\n\nAffected packages and fixed versions:\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84314/ (Markdown: https://insights.sbomify.com/CVE-2026-84314/index.md)","id":"CVE-2026-84314","markdown":"https://insights.sbomify.com/CVE-2026-84314/index.md","name":"CVE-2026-84314","record":{"aliases":["GHSA-2gc7-j998-5xx6","GO-2026-6771"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Nginx web UI","requires_auth":"low_privilege","summary":"Authenticated users can bypass session security checks to change administrator passwords and take over the Nginx UI account.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint","id":"CVE-2026-84314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Nginx UI OTP secure-session step-up is missing on sensitive mutation routes","id":"CVE-2026-84315"},"packages":[{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":null,"source":"GHSA-2gc7-j998-5xx6"},{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":"pkg:golang/github.com/0xJacky/Nginx-UI","source":"GHSA-2gc7-j998-5xx6"},{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":"pkg:golang/github.com/0xJacky/Nginx-UI","source":"GO-2026-6771"}],"prev":{"headline":"Nginx UI: TOTP / passkey enrolment requires no re-authentication, enabling persistent account takeover","id":"CVE-2026-84313"},"products":["nginx-ui"],"published":"2026-10-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["0xJacky"]},"summary":"Authenticated users can bypass session security checks to change administrator passwords and take over the Nginx UI account.","url":"https://insights.sbomify.com/CVE-2026-84314/"}