CVE-2026-84316 Nginx UI: nginx config directive denylist (ValidateConfigFile) is bypassable via same-line ";" separation → authenticated directive injection (RCE on the official image)
Authenticated attackers can bypass Nginx config validation to inject malicious directives, leading to remote code execution on the server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-84316?
CVE-2026-84316 is a high-severity code injection vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, config.ValidateConfigDirectives splits configuration by newline and checks only the first directive token on each line even though Nginx permits multiple semicolon-separated directives on one line. An authenticated caller can place a benign directive first and a restricted load_module, js_import, perl, or user root directive later on the same line, or can use an unrestricted include directive to load restricted content. These mechanisms bypass validation on REST, nginx_config_modify, site, and stream write paths; when an executable module is available, the injected configuration can execute code in the Nginx worker context. This issue is fixed in version 2.4.1.
Which versions are affected by CVE-2026-84316?
3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.
| Package | Affected | Fixed in |
|---|---|---|
github.com/0xJacky/Nginx-UI Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
github.com/0xJacky/Nginx-UI Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
github.com/0xJacky/Nginx-UI Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
How do I fix CVE-2026-84316?
Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-84316 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84316 exists.
Sources
Also known as GHSA-cf23-7qxj-xmhr, GO-2026-6782.