# CVE-2026-84319: Nginx UI: MCP configuration tools bypass restricted directive validation and allow secondary authenticated users to execute NJS in Nginx worker context

> Authenticated users can bypass directive restrictions via MCP tools to execute arbitrary JavaScript in the Nginx worker context.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-5r62-gj48-897x, GO-2026-6774

## What is CVE-2026-84319?

CVE-2026-84319 is a high-severity vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the regular HTTP configuration API rejects restricted Nginx directives such as load_module, js_import, and js_content. However, the MCP configuration interface allows a secondary authenticated user to write and apply equivalent restricted configuration content. This allows the user to load ngx_http_js_module.so, import attacker-controlled JavaScript, reload Nginx, and execute NJS in the Nginx worker context. This issue is fixed in version 2.4.1.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-84319?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |

## How do I fix CVE-2026-84319?

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.

## Is CVE-2026-84319 being exploited?

There is no known exploitation of CVE-2026-84319 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84319 and fix it if it is affected.

What it is: CVE-2026-84319 is a high-severity vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84319 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84319/ (Markdown: https://insights.sbomify.com/CVE-2026-84319/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84319
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84319
- OSV: https://osv.dev/vulnerability/CVE-2026-84319

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84319/
Summaries are generated and may contain mistakes; the official description above is the record.
