CVE-2026-84360 Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools
Attackers with normal authentication can bypass OTP step-up requirements to modify Nginx configurations via MCP tools, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-84360?
CVE-2026-84360 is a high-severity vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.
Weakness: CWE-288
Which versions are affected by CVE-2026-84360?
3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.
| Package | Affected | Fixed in |
|---|---|---|
github.com/0xJacky/Nginx-UI Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
github.com/0xJacky/Nginx-UI Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
github.com/0xJacky/Nginx-UI Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
How do I fix CVE-2026-84360?
Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.
Is CVE-2026-84360 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84360 exists.
Sources
Also known as GHSA-vc32-4gwf-77xp, GO-2026-6799.