{"answers":{"affected":"3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84360 exists.","fix":"Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.","what":"CVE-2026-84360 is a high-severity vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-84360 and fix it if it is affected.\n\nWhat it is: CVE-2026-84360 is a high-severity vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84360 exists.\n\nAffected packages and fixed versions:\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84360/ (Markdown: https://insights.sbomify.com/CVE-2026-84360/index.md)","id":"CVE-2026-84360","markdown":"https://insights.sbomify.com/CVE-2026-84360/index.md","name":"CVE-2026-84360","record":{"aliases":["GHSA-vc32-4gwf-77xp","GO-2026-6799"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Nginx web UI","requires_auth":"low_privilege","summary":"Attackers with normal authentication can bypass OTP step-up requirements to modify Nginx configurations via MCP tools, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"}],"description":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools","id":"CVE-2026-84360","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Composer: Perforce source URL permits P4PORT `rsh:` command execution","id":"CVE-2026-84361"},"packages":[{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":null,"source":"GHSA-vc32-4gwf-77xp"},{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":"pkg:golang/github.com/0xJacky/Nginx-UI","source":"GHSA-vc32-4gwf-77xp"},{"ecosystem":"Go","fixed":["1.9.10-0.20260703131214-23d1934099b0"],"introduced":["0"],"last_affected":[],"package":"github.com/0xJacky/Nginx-UI","purl":"pkg:golang/github.com/0xJacky/Nginx-UI","source":"GO-2026-6799"}],"prev":{"headline":"Information disclosure in Chrome","id":"CVE-2026-84359"},"products":["nginx-ui"],"published":"2026-10-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["0xJacky"]},"summary":"Attackers with normal authentication can bypass OTP step-up requirements to modify Nginx configurations via MCP tools, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-84360/"}