# CVE-2026-84360: Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools

> Attackers with normal authentication can bypass OTP step-up requirements to modify Nginx configurations via MCP tools, potentially leading to code execution.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-vc32-4gwf-77xp, GO-2026-6799

## What is CVE-2026-84360?

CVE-2026-84360 is a high-severity vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-84360?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 1.9.10-0.20260703131214-23d1934099b0 |

## How do I fix CVE-2026-84360?

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.

## Is CVE-2026-84360 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84360 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84360 and fix it if it is affected.

What it is: CVE-2026-84360 is a high-severity vulnerability in 0xJacky nginx-ui, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84360 exists.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 1.9.10-0.20260703131214-23d1934099b0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84360/ (Markdown: https://insights.sbomify.com/CVE-2026-84360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84360
- OSV: https://osv.dev/vulnerability/CVE-2026-84360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84360/
Summaries are generated and may contain mistakes; the official description above is the record.
