CVE-2026-84377 LiteLLM: Authenticated SSRF and provider-credential exfiltration via unvalidated request-body routing parameters
Authenticated users can redirect proxy requests to attacker-controlled destinations, exfiltrating provider credentials and accessing internal services.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-84377?
CVE-2026-84377 is a medium-severity server-side request forgery vulnerability in BerriAI litellm, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to versions 1.88.6 and 1.96.2, any authenticated LiteLLM proxy user could redirect an outbound provider call to a destination the user controls and cause the proxy to send its configured provider credentials to that destination. Request validation in litellm/proxy/auth/auth_utils.py, litellm/proxy/common_request_processing.py, litellm/proxy/health_endpoints/_health_endpoints.py, litellm/proxy/image_endpoints/endpoints.py, and litellm/proxy/litellm_pre_call_utils.py used incomplete checks that did not cover every sensitive parameter or inspect equivalent values across nested request fields, path values, and bracket-notation form data. Routing and credential parameters including api_base, base_url, model_list, fallbacks, and litellm_credential_name could therefore be applied without clearing the operator's stored key, exposing upstream provider credentials and other configured secrets and permitting server-side requests to internal services reachable by the proxy. This issue is fixed in versions 1.88.6 and 1.96.2.
Weakness: CWE-918
Which versions are affected by CVE-2026-84377?
19 open source packages ship an affected version, including litellm.
| Package | Affected | Fixed in |
|---|---|---|
litellm PyPI | All versions | 1.88.6, 1.89.7, 1.90.7, 1.91.5, 1.92.2, 1.93.2, 1.94.3, 1.95.1, 1.96.2 |
litellm PyPI | All versions | 1.88.6 |
litellm PyPI | All versions | 1.88.6 |
litellm PyPI | From 1.89.0 | 1.89.7 |
litellm PyPI | From 1.89.0 | 1.89.7 |
litellm PyPI | From 1.90.0 | 1.90.7 |
13 more packages
litellm PyPI | From 1.90.0 | 1.90.7 |
litellm PyPI | From 1.91.0 | 1.91.5 |
litellm PyPI | From 1.91.0 | 1.91.5 |
litellm PyPI | From 1.92.0 | 1.92.2 |
litellm PyPI | From 1.92.0 | 1.92.2 |
litellm PyPI | From 1.93.0 | 1.93.2 |
litellm PyPI | From 1.93.0 | 1.93.2 |
litellm PyPI | From 1.94.0 | 1.94.3 |
litellm PyPI | From 1.94.0 | 1.94.3 |
litellm PyPI | From 1.95.0 | 1.95.1 |
litellm PyPI | From 1.95.0 | 1.95.1 |
litellm PyPI | From 1.96.0 | 1.96.2 |
litellm PyPI | From 1.96.0 | 1.96.2 |
Linux distribution packages (1)
python-litellm openSUSE:Tumbleweed | All versions | 1.101.0-1.1 |
How do I fix CVE-2026-84377?
Upgrade litellm to a fixed version for your release line: 1.88.6, 1.89.7, 1.90.7 or 1.91.5.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-84377 being exploited?
There is no known exploitation of CVE-2026-84377 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-XQ90781, ECHO-53c1-fa3e-1fea, GHSA-3cv6-jpf6-8222, MINI-48mp-q4hp-rqvg, MINI-5jqp-fg9w-p3mp, MINI-5mxh-gw4p-x9r5 and 13 more.