# CVE-2026-84377: LiteLLM: Authenticated SSRF and provider-credential exfiltration via unvalidated request-body routing parameters

> Authenticated users can redirect proxy requests to attacker-controlled destinations, exfiltrating provider credentials and accessing internal services.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 3 Sep 2026
- **Also known as:** CLEANSTART-2026-XQ90781, ECHO-53c1-fa3e-1fea, GHSA-3cv6-jpf6-8222, MINI-48mp-q4hp-rqvg, MINI-5jqp-fg9w-p3mp, MINI-5mxh-gw4p-x9r5, MINI-6pvj-3mfj-wj9r, MINI-78fj-j6w6-768g, MINI-853m-q639-g39f, MINI-8hwp-mvvw-r289, MINI-mpvc-743v-w696, MINI-pj3h-g26w-35m4, MINI-qhqh-j4xm-rh36, MINI-rfwx-7ppx-vcwv, MINI-vp98-xjhc-f9c5, MINI-xfm4-hx3j-4jxh, MINI-xh4h-hfhm-vc4c, PYSEC-2026-4066, openSUSE-SU-2026:11800-1

## What is CVE-2026-84377?

CVE-2026-84377 is a medium-severity server-side request forgery vulnerability in BerriAI litellm, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to versions 1.88.6 and 1.96.2, any authenticated LiteLLM proxy user could redirect an outbound provider call to a destination the user controls and cause the proxy to send its configured provider credentials to that destination. Request validation in litellm/proxy/auth/auth_utils.py, litellm/proxy/common_request_processing.py, litellm/proxy/health_endpoints/_health_endpoints.py, litellm/proxy/image_endpoints/endpoints.py, and litellm/proxy/litellm_pre_call_utils.py used incomplete checks that did not cover every sensitive parameter or inspect equivalent values across nested request fields, path values, and bracket-notation form data. Routing and credential parameters including api_base, base_url, model_list, fallbacks, and litellm_credential_name could therefore be applied without clearing the operator's stored key, exposing upstream provider credentials and other configured secrets and permitting server-side requests to internal services reachable by the proxy. This issue is fixed in versions 1.88.6 and 1.96.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-84377?

19 open source packages ship an affected version, including litellm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.88.6, 1.89.7, 1.90.7, 1.91.5, 1.92.2, 1.93.2, 1.94.3, 1.95.1, 1.96.2 |
| `litellm` | PyPI | All versions | 1.88.6 |
| `litellm` | PyPI | All versions | 1.88.6 |
| `litellm` | PyPI | From 1.89.0 | 1.89.7 |
| `litellm` | PyPI | From 1.89.0 | 1.89.7 |
| `litellm` | PyPI | From 1.90.0 | 1.90.7 |
| `litellm` | PyPI | From 1.90.0 | 1.90.7 |
| `litellm` | PyPI | From 1.91.0 | 1.91.5 |
| `litellm` | PyPI | From 1.91.0 | 1.91.5 |
| `litellm` | PyPI | From 1.92.0 | 1.92.2 |
| `litellm` | PyPI | From 1.92.0 | 1.92.2 |
| `litellm` | PyPI | From 1.93.0 | 1.93.2 |
| `litellm` | PyPI | From 1.93.0 | 1.93.2 |
| `litellm` | PyPI | From 1.94.0 | 1.94.3 |
| `litellm` | PyPI | From 1.94.0 | 1.94.3 |
| `litellm` | PyPI | From 1.95.0 | 1.95.1 |
| `litellm` | PyPI | From 1.95.0 | 1.95.1 |
| `litellm` | PyPI | From 1.96.0 | 1.96.2 |
| `litellm` | PyPI | From 1.96.0 | 1.96.2 |
| `python-litellm` | openSUSE:Tumbleweed | All versions | 1.101.0-1.1 |

## How do I fix CVE-2026-84377?

Upgrade litellm to a fixed version for your release line: 1.88.6, 1.89.7, 1.90.7 or 1.91.5.

## Is CVE-2026-84377 being exploited?

There is no known exploitation of CVE-2026-84377 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84377 and fix it if it is affected.

What it is: CVE-2026-84377 is a medium-severity server-side request forgery vulnerability in BerriAI litellm, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84377 in the wild and no public exploit code.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.88.6, 1.89.7, 1.90.7, 1.91.5, 1.92.2, 1.93.2, 1.94.3, 1.95.1, 1.96.2
- litellm (PyPI): affected all versions; fixed in 1.88.6
- litellm (PyPI): affected all versions; fixed in 1.88.6
- litellm (PyPI): affected from 1.89.0; fixed in 1.89.7
- litellm (PyPI): affected from 1.89.0; fixed in 1.89.7
- litellm (PyPI): affected from 1.90.0; fixed in 1.90.7
- litellm (PyPI): affected from 1.90.0; fixed in 1.90.7
- litellm (PyPI): affected from 1.91.0; fixed in 1.91.5
- litellm (PyPI): affected from 1.91.0; fixed in 1.91.5
- litellm (PyPI): affected from 1.92.0; fixed in 1.92.2
- litellm (PyPI): affected from 1.92.0; fixed in 1.92.2
- litellm (PyPI): affected from 1.93.0; fixed in 1.93.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84377/ (Markdown: https://insights.sbomify.com/CVE-2026-84377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84377
- OSV: https://osv.dev/vulnerability/CVE-2026-84377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84377/
Summaries are generated and may contain mistakes; the official description above is the record.
