# CVE-2026-84378: HTTPX2: Quadratic SSE line buffering can cause CPU denial of service

> A crafted Server-Sent Events stream can cause quadratic CPU consumption in the HTTPX2 library, leading to denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 2 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-84378, ECHO-e305-29d2-dcb3, GHSA-f2fp-rgf2-35cp, MINI-485q-xq5h-m8rc, PYSEC-2026-3847, UBUNTU-CVE-2026-84378

## What is CVE-2026-84378?

CVE-2026-84378 is a medium-severity denial of service vulnerability in pydantic httpx2, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HTTPX2 is a next generation HTTP client for Python. From 2.5.0 until 2.10.0, the HTTPX2 Server-Sent Events parser in src/httpx2/httpx2/_sse.py repeatedly copies and rescans buffered text in _SSELineDecoder.decode() when an attacker-controlled or compromised SSE endpoint splits one unterminated line across many response chunks. The behavior affects httpx2.Client.sse() and httpx2.AsyncClient.sse(), and the total processing work grows quadratically with the line length, allowing a crafted stream to consume excessive CPU and block a synchronous worker or asynchronous event loop. This issue is fixed in version 2.10.0.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-84378?

3 open source packages ship an affected version, including httpx2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpx2` | PyPI | From 2.5.0 | 2.10.0 |
| `httpx2` | PyPI | From 2.5.0 | 2.10.0 |
| `httpx2` | PyPI | From 2.5.0 | 2.10.0 |

## How do I fix CVE-2026-84378?

Upgrade httpx2 to 2.10.0 or later.

## Is CVE-2026-84378 being exploited?

There is no known exploitation of CVE-2026-84378 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84378 and fix it if it is affected.

What it is: CVE-2026-84378 is a medium-severity denial of service vulnerability in pydantic httpx2, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84378 in the wild and no public exploit code.

Affected packages and fixed versions:
- httpx2 (PyPI): affected from 2.5.0; fixed in 2.10.0
- httpx2 (PyPI): affected from 2.5.0; fixed in 2.10.0
- httpx2 (PyPI): affected from 2.5.0; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84378/ (Markdown: https://insights.sbomify.com/CVE-2026-84378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84378
- OSV: https://osv.dev/vulnerability/CVE-2026-84378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84378/
Summaries are generated and may contain mistakes; the official description above is the record.
