# CVE-2026-84382: HTTPX2: Streaming response decompression does not bound peak memory (decompression amplification)

> An attacker can cause out-of-memory termination in applications using HTTPX2 by sending compressed chunks that expand excessively during streaming.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 3 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-84382, ECHO-874b-ad07-3e0f, GHSA-8xx6-hgc6-gc2m, MINI-3r7q-5vj5-j568, MINI-xh52-9x6m-5mpg, PYSEC-2026-3846, ROOT-APP-PYPI-CVE-2026-84382, UBUNTU-CVE-2026-84382

## What is CVE-2026-84382?

CVE-2026-84382 is a high-severity denial of service vulnerability in pydantic httpx2, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HTTPX2 is a next generation HTTP client for Python. Prior to 2.12.0, the HTTPX2 content decoders in src/httpx2/httpx2/_decoders.py fully inflate each gzip, deflate, br, or zstd network chunk before iter_bytes() or aiter_bytes() yields bounded pieces to the application. A 64 KiB compressed chunk can expand to approximately 64 MiB in one intermediate allocation, so an attacker-controlled or compromised server can cause severe memory pressure or out-of-memory process termination even when the application streams the response. This issue is fixed in version 2.12.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-84382?

3 open source packages ship an affected version, including httpx2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpx2` | PyPI | All versions | 2.12.0 |
| `httpx2` | PyPI | All versions | 2.12.0 |
| `httpx2` | PyPI | All versions | 2.12.0 |

## How do I fix CVE-2026-84382?

Upgrade httpx2 to 2.12.0 or later.

## Is CVE-2026-84382 being exploited?

There is no known exploitation of CVE-2026-84382 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84382 and fix it if it is affected.

What it is: CVE-2026-84382 is a high-severity denial of service vulnerability in pydantic httpx2, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84382 in the wild and no public exploit code.

Affected packages and fixed versions:
- httpx2 (PyPI): affected all versions; fixed in 2.12.0
- httpx2 (PyPI): affected all versions; fixed in 2.12.0
- httpx2 (PyPI): affected all versions; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84382/ (Markdown: https://insights.sbomify.com/CVE-2026-84382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84382
- OSV: https://osv.dev/vulnerability/CVE-2026-84382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84382/
Summaries are generated and may contain mistakes; the official description above is the record.
