# CVE-2026-84439: Apache ZooKeeper: Audit log injection via unsanitized output from multiple sources

> Attackers can inject forged fields into ZooKeeper audit logs via unsanitized input, corrupting forensic evidence and bypassing security monitoring.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-zookeeper-2026-84439, CLEANSTART-2026-DM89107, CLEANSTART-2026-MZ33445, CLEANSTART-2026-QY26018, CLEANSTART-2026-WQ92257, DEBIAN-CVE-2026-84439, GHSA-mxvw-9w3g-hmrq, MINI-jvcg-72p3-4262, MINI-p9rc-6q36-vh92, UBUNTU-CVE-2026-84439

## What is CVE-2026-84439?

CVE-2026-84439 is a medium-severity vulnerability in Apache ZooKeeper, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When audit logging is enabled (zookeeper.audit.enable=true), an unauthenticated attacker can inject arbitrary fields into Apache ZooKeeper's audit log by sending a digest authentication request with tab characters (\t) embedded in the username. Because the audit log uses tab-separated key=value format, the injected tabs are parsed as legitimate field separators, allowing the attacker to spoof audit results (e.g., injecting result=success), forge operation types, and corrupt forensic evidence.

A log injection vulnerability in Apache ZooKeeper allows a client that can call setACL to inject forged key-value fields into zookeeper_audit.log. When audit logging is enabled, the server serializes attacker-controlled digest ACL ids into the acl= audit field without escaping tab characters. Because audit events are emitted as tab-separated key=value records, a crafted ACL id can make one successful setAcl event appear to contain forged fields such as operation=delete and znode=/forged. This undermines the integrity of downstream audit parsing, alerting, and incident response.

This issue affects Apache ZooKeeper: from 3.9.0 through 3.9.5, from 3.8.0 through 3.8.6.

Users are recommended to upgrade to version 3.9.6 or 3.8.7, which fixes the issue.

Weakness: CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2026-84439?

1 open source package ship an affected version, including zookeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zookeeper` | Bitnami | From 3.8.0 | 3.8.7, 3.9.6 |

Products: Apache Zookeeper.

## How do I fix CVE-2026-84439?

Upgrade zookeeper to a fixed version for your release line: 3.8.7 or 3.9.6.

## Is CVE-2026-84439 being exploited?

There is no known exploitation of CVE-2026-84439 in the wild and no public exploit code.

## Other vulnerabilities in Apache ZooKeeper

- [CVE-2024-51504](https://insights.sbomify.com/CVE-2024-51504/): Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server (critical 9.1)
- [CVE-2023-44981](https://insights.sbomify.com/CVE-2023-44981/): Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication (critical 9.1)
- [CVE-2016-5017](https://insights.sbomify.com/CVE-2016-5017/): Memory corruption in n/a (high 8.1)
- [CVE-2026-59739](https://insights.sbomify.com/CVE-2026-59739/): Apache ZooKeeper: Information disclosure via SetWatches reconnect replay (high 7.5)
- [CVE-2026-59969](https://insights.sbomify.com/CVE-2026-59969/): Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84439 and fix it if it is affected.

What it is: CVE-2026-84439 is a medium-severity vulnerability in Apache ZooKeeper, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84439 in the wild and no public exploit code.

Affected packages and fixed versions:
- zookeeper (Bitnami): affected from 3.8.0; fixed in 3.8.7, 3.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84439/ (Markdown: https://insights.sbomify.com/CVE-2026-84439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84439
- OSV: https://osv.dev/vulnerability/CVE-2026-84439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84439/
Summaries are generated and may contain mistakes; the official description above is the record.
