# CVE-2026-84447: Denial of service in libheif

> Crafted HEIF/AVIF files can cause excessive CPU and memory usage in libheif, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** BELL-CVE-2026-84447, DEBIAN-CVE-2026-84447, ECHO-780c-8092-a9bc, GHSA-x8xm-cm2c-cfc8, MINI-jm44-m948-pxc4, ROOT-OS-DEBIAN-12-CVE-2026-84447, UBUNTU-CVE-2026-84447

## What is CVE-2026-84447?

CVE-2026-84447 is a high-severity denial of service vulnerability in strukturag libheif, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libheif is a HEIF and AVIF file format decoder and encoder. In 1.23.1 and earlier, crafted grid, iovl, and iden reference graphs can repeatedly decode the same base image because processed_ids is copied per branch and ImageItem::decode_image() has no shared operation budget. This vulnerability is fixed in 1.23.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-84447?


## How do I fix CVE-2026-84447?

Upgrade to a fixed version.

## Is CVE-2026-84447 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84447 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84447 and fix it if it is affected.

What it is: CVE-2026-84447 is a high-severity denial of service vulnerability in strukturag libheif, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-84447 exists.

Affected product: strukturag libheif. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84447/ (Markdown: https://insights.sbomify.com/CVE-2026-84447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84447
- OSV: https://osv.dev/vulnerability/CVE-2026-84447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84447/
Summaries are generated and may contain mistakes; the official description above is the record.
