# CVE-2026-8445: justhtml before 1.12.0 Sanitizer Bypass via Markdown

> An attacker can bypass HTML sanitization in justhtml by injecting raw HTML via Markdown conversion, leading to cross-site scripting when the output is rendered.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** GHSA-3rcm-vjrc-p45j, GHSA-wf6m-786j-gxrr

## What is CVE-2026-8445?

CVE-2026-8445 is a critical cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

justhtml versions <= 1.11.0 (fixed in 1.12.0) do not sufficiently escape HTML-significant characters (angle brackets) in text nodes when converting a parsed document to Markdown via to_markdown(). While a small set of Markdown metacharacters are escaped, characters such as < and > are preserved, so untrusted input that is safe in to_html() — including entity-decoded text (e.g. &lt;script&gt;) or text from RCDATA/RAWTEXT-parsed elements like <title>, <textarea>, <noscript>, and <plaintext> — can be emitted as raw HTML in the Markdown output, enabling a sanitizer bypass and potential cross-site scripting when that output is rendered.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-8445?

2 open source packages ship an affected version, including justhtml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `justhtml` | PyPI | All versions | 1.12.0 |
| `justhtml` | PyPI | All versions | 1.12.0 |

## How do I fix CVE-2026-8445?

Upgrade justhtml to 1.12.0 or later.

## Is CVE-2026-8445 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8445 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8445 and fix it if it is affected.

What it is: CVE-2026-8445 is a critical cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8445 exists.

Affected packages and fixed versions:
- justhtml (PyPI): affected all versions; fixed in 1.12.0
- justhtml (PyPI): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8445/ (Markdown: https://insights.sbomify.com/CVE-2026-8445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8445
- OSV: https://osv.dev/vulnerability/CVE-2026-8445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8445/
Summaries are generated and may contain mistakes; the official description above is the record.
