# CVE-2026-84462: Zammad: AI Agent template sanitizer bypass leads to remote code execution

> Administrators can bypass AI Agent sanitization to execute arbitrary commands on the server, compromising all stored data.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-gp3x-9xm8-rcj6

## What is CVE-2026-84462?

CVE-2026-84462 is a high-severity code injection vulnerability in zammad, published on 25 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.1.2, a security filter that protects Zammad's AI Agent configuration can be bypassed by entering specially crafted text into one of an AI Agent's fields. An administrator with permission to create or edit AI Agents could exploit this to run arbitrary commands on the server that hosts Zammad, potentially reading, modifying, or destroying all data stored on that server. No interaction from other users is needed; the malicious code runs automatically the next time the affected AI Agent processes a ticket. This issue is fixed in version 7.1.2.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-84462?


## How do I fix CVE-2026-84462?

No fix has been published for CVE-2026-84462 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-84462 being exploited?

There is no known exploitation of CVE-2026-84462 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84462 and fix it if it is affected.

What it is: CVE-2026-84462 is a high-severity code injection vulnerability in zammad, published on 25 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84462 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84462/ (Markdown: https://insights.sbomify.com/CVE-2026-84462/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84462
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84462
- OSV: https://osv.dev/vulnerability/CVE-2026-84462

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84462/
Summaries are generated and may contain mistakes; the official description above is the record.
