# CVE-2026-84463: Cross-site scripting in zammad

> Attackers with KB editing rights can inject HTML to force session switching, allowing unauthorized access to other user accounts.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-cxjg-4gmf-5xqc

## What is CVE-2026-84463?

CVE-2026-84463 is a medium-severity cross-site scripting vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.1.2, a user with Knowledge Base editing rights for a category can embed a video widget in a published answer with a specially crafted value. When the answer is rendered, that value is inserted into the page's HTML without being escaped for its attribute context, allowing it to break out and inject additional HTML into the page. When another user who has permission to switch between user sessions views the affected answer, the injected HTML causes their browser to silently send a request to Zammad's session-switching endpoint using their own active credentials. This results in switching their session to an account chosen by the person who wrote the Knowledge Base answer. No action is required from the viewer beyond opening the published answer. This issue is fixed in version 7.1.2.

Weakness: CWE-838 (Inappropriate Encoding for Output Context), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-84463?


## How do I fix CVE-2026-84463?

No fix has been published for CVE-2026-84463 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-84463 being exploited?

There is no known exploitation of CVE-2026-84463 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84463 and fix it if it is affected.

What it is: CVE-2026-84463 is a medium-severity cross-site scripting vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-84463 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84463/ (Markdown: https://insights.sbomify.com/CVE-2026-84463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84463
- OSV: https://osv.dev/vulnerability/CVE-2026-84463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84463/
Summaries are generated and may contain mistakes; the official description above is the record.
