# CVE-2026-84469: fastify vulnerable to request validation bypass via skipped boolean false schemas

> Attackers can bypass request validation in Fastify by exploiting a truthiness bug, allowing unauthorized access to handlers intended to be disabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLSA-2026-1791667225, GHSA-hwr6-493r-vm6h, MINI-82m3-26hw-q684

## What is CVE-2026-84469?

CVE-2026-84469 is a high-severity vulnerability in fastify, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fastify versions before 5.12.2 decide whether to compile a request schema based on JavaScript truthiness, but JSON Schema Draft 7 defines the boolean false as a valid schema that rejects every instance. When an application assigns false to a route's body, querystring, params, or headers schema to deny all input, fastify treats it as a missing schema, compiles no validator, and runs the route handler on any request. An unauthenticated remote client can therefore reach a handler that a valid deny-all schema was intended to make unreachable, a complete validation bypass that can lead to unauthorized state changes or execution of disabled operations. Users should upgrade to fastify 5.12.2 or later.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-84469?

2 open source packages ship an affected version, including fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | All versions | 5.12.2 |
| `fastify` | npm | All versions | 5.12.2 |

Products: Fastify Fastify.

## How do I fix CVE-2026-84469?

Upgrade fastify to 5.12.2 or later.

## Is CVE-2026-84469 being exploited?

There is no known exploitation of CVE-2026-84469 in the wild and no public exploit code.

## Other vulnerabilities in fastify

- [CVE-2026-84504](https://insights.sbomify.com/CVE-2026-84504/): fastify vulnerable to request body replacement via an async validation result collision (high 8.1)
- [CVE-2026-76169](https://insights.sbomify.com/CVE-2026-76169/): fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers (high 7.5)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)
- [CVE-2026-25223](https://insights.sbomify.com/CVE-2026-25223/): Fastify's Content-Type header tab character allows body validation bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84469 and fix it if it is affected.

What it is: CVE-2026-84469 is a high-severity vulnerability in fastify, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84469 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected all versions; fixed in 5.12.2
- fastify (npm): affected all versions; fixed in 5.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84469/ (Markdown: https://insights.sbomify.com/CVE-2026-84469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84469
- OSV: https://osv.dev/vulnerability/CVE-2026-84469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84469/
Summaries are generated and may contain mistakes; the official description above is the record.
