# CVE-2026-84504: fastify vulnerable to request body replacement via an async validation result collision

> An authenticated low-privilege user can replace the validated request body with nested data, bypassing schema authorization to modify or read unauthorized data.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLSA-2026-1790870980, CLSA-2026-1790937680, CLSA-2026-1790966173, CLSA-2026-1791028128, CLSA-2026-1791050166, CLSA-2026-1791052604, GHSA-667r-xxjv-c9mm, MINI-4c6x-w9g8-ch8c

## What is CVE-2026-84504?

CVE-2026-84504 is a high-severity vulnerability in fastify, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

fastify versions before 5.12.2 treat the object resolved by a successful Ajv async validator as the value result protocol used by custom validator compilers. If a request that passes its route schema contains a property named value at the root, fastify replaces the entire request body with that property's value before the handler runs, so the handler receives a different object than the one that satisfied the schema. An authenticated low-privilege caller can use this to make nested data replace the validated body and trigger an operation the route schema did not authorize, leading to unauthorized state changes and data disclosure. Users should upgrade to fastify 5.12.2 or later.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-84504?

2 open source packages ship an affected version, including fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | All versions | 5.12.2 |
| `fastify` | npm | All versions | 5.12.2 |

Products: Fastify Fastify.

## How do I fix CVE-2026-84504?

Upgrade fastify to 5.12.2 or later.

## Is CVE-2026-84504 being exploited?

There is no known exploitation of CVE-2026-84504 in the wild and no public exploit code.

## Other vulnerabilities in fastify

- [CVE-2026-76169](https://insights.sbomify.com/CVE-2026-76169/): fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers (high 7.5)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-84469](https://insights.sbomify.com/CVE-2026-84469/): fastify vulnerable to request validation bypass via skipped boolean false schemas (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)
- [CVE-2026-25223](https://insights.sbomify.com/CVE-2026-25223/): Fastify's Content-Type header tab character allows body validation bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84504 and fix it if it is affected.

What it is: CVE-2026-84504 is a high-severity vulnerability in fastify, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84504 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected all versions; fixed in 5.12.2
- fastify (npm): affected all versions; fixed in 5.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84504/ (Markdown: https://insights.sbomify.com/CVE-2026-84504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84504
- OSV: https://osv.dev/vulnerability/CVE-2026-84504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84504/
Summaries are generated and may contain mistakes; the official description above is the record.
