CVE-2026-84647 Deserialization in Jenkins
Attackers with read permissions can instantiate unintended configuration objects via form data binding, potentially leading to privilege escalation or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-84647?
CVE-2026-84647 is a high-severity unsafe deserialization vulnerability in Jenkins, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Stapler 2107.v8dfcb_e8ed317 and earlier, except 2088.2093.vd7c3e58008a_6, included in Jenkins 2.579 and earlier, LTS 2.568.2 and earlier, Stapler does not restrict the types of objects that can be instantiated via form data binding to those compatible with the expected field type, allowing attackers with Overall/Read permission to instantiate types related to configuration for which that field type was not intended.
Weakness: CWE-502
Which versions are affected by CVE-2026-84647?
1 open source package ship an affected version, including jenkins.
| Package | Affected | Fixed in |
|---|---|---|
jenkins Bitnami | All versions | 2.568.3, 2.580.0 |
How do I fix CVE-2026-84647?
Upgrade jenkins to a fixed version for your release line: 2.568.3 or 2.580.0.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-84647 being exploited?
There is no known exploitation of CVE-2026-84647 in the wild and no public exploit code.
Sources
Also known as BIT-jenkins-2026-84647, GHSA-45rc-jrc6-vpjg, MINI-53v5-xfww-5vmr, MINI-69px-r66p-8rjg, MINI-8fq8-gvmv-qcxx, MINI-mhc4-8cvp-xg5f and 3 more.