# CVE-2026-84647: Deserialization in Jenkins

> Attackers with read permissions can instantiate unintended configuration objects via form data binding, potentially leading to privilege escalation or code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-jenkins-2026-84647, GHSA-45rc-jrc6-vpjg, MINI-53v5-xfww-5vmr, MINI-69px-r66p-8rjg, MINI-8fq8-gvmv-qcxx, MINI-mhc4-8cvp-xg5f, MINI-q5c5-3cx9-mwgg, MINI-whr9-fp77-3362, MINI-x64q-5343-cm46

## What is CVE-2026-84647?

CVE-2026-84647 is a high-severity unsafe deserialization vulnerability in Jenkins, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Stapler 2107.v8dfcb_e8ed317 and earlier, except 2088.2093.vd7c3e58008a_6, included in Jenkins 2.579 and earlier, LTS 2.568.2 and earlier, Stapler does not restrict the types of objects that can be instantiated via form data binding to those compatible with the expected field type, allowing attackers with Overall/Read permission to instantiate types related to configuration for which that field type was not intended.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-84647?

1 open source package ship an affected version, including jenkins.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jenkins` | Bitnami | All versions | 2.568.3, 2.580.0 |

## How do I fix CVE-2026-84647?

Upgrade jenkins to a fixed version for your release line: 2.568.3 or 2.580.0.

## Is CVE-2026-84647 being exploited?

There is no known exploitation of CVE-2026-84647 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84647 and fix it if it is affected.

What it is: CVE-2026-84647 is a high-severity unsafe deserialization vulnerability in Jenkins, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84647 in the wild and no public exploit code.

Affected packages and fixed versions:
- jenkins (Bitnami): affected all versions; fixed in 2.568.3, 2.580.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84647/ (Markdown: https://insights.sbomify.com/CVE-2026-84647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84647
- OSV: https://osv.dev/vulnerability/CVE-2026-84647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84647/
Summaries are generated and may contain mistakes; the official description above is the record.
