CVE-2026-84648 Cross-site scripting in Jenkins

High 8.8 Published Updated

Attackers controlling agent processes can inject malicious scripts into Jenkins system logs, leading to stored XSS and potential session hijacking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-84648?

CVE-2026-84648 is a high-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In Jenkins 2.579 and earlier, LTS 2.568.2 and earlier, the system log viewer does not escape log record metadata (source, level, and timestamp) resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers in control of agent processes.

Weakness: CWE-79

Which versions are affected by CVE-2026-84648?

1 open source package ship an affected version, including jenkins. It affects 1 product.

PackageAffectedFixed in
jenkins BitnamiAll versions2.568.3, 2.580.0

Products include Jenkins Jenkins.

How do I fix CVE-2026-84648?

Upgrade jenkins to a fixed version for your release line: 2.568.3 or 2.580.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-84648 being exploited?

There is no known exploitation of CVE-2026-84648 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as BIT-jenkins-2026-84648, GHSA-qgwr-f9q8-fxgq, MINI-4274-mx59-jx46, MINI-44v2-762f-cgrg, MINI-8fvx-738p-8h7r, MINI-cg65-frpq-mrwj and 3 more.

Is CVE-2026-84648 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free