# CVE-2026-84649: Cross-site request forgery in Jenkins

> Attackers can steal CSRF tokens from Jenkins JavaScript endpoints to perform unauthorized actions on behalf of users.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-jenkins-2026-84649, GHSA-hxvq-fvg2-gh6m, MINI-2q2x-qq6c-58mj, MINI-5c2x-66g3-7pf5, MINI-8572-634m-84mp, MINI-h2c6-r247-q7x5, MINI-m9mq-r747-77xp, MINI-pr3r-9p28-r5c3, MINI-v3vf-gr2h-64wg

## What is CVE-2026-84649?

CVE-2026-84649 is a high-severity vulnerability in Jenkins, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Stapler 1839.ved17667b_a_eb_5 through 2107.v8dfcb_e8ed317 (both inclusive), except 2088.2093.vd7c3e58008a_6, included in Jenkins 2.447 through 2.579 (both inclusive), LTS 2.452.1 through 2.568.2 (both inclusive), an HTTP endpoint serving dynamically generated JavaScript resources embeds the user's cross-site request forgery (CSRF) token (crumb) as a string literal, allowing attackers with control over a page hosted on the same site as Jenkins to obtain a valid crumb for the targeted user's session and perform actions on their behalf.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-84649?

1 open source package ship an affected version, including jenkins.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jenkins` | Bitnami | From 2.447.0 | 2.568.3, 2.580.0 |

## How do I fix CVE-2026-84649?

Upgrade jenkins to a fixed version for your release line: 2.568.3 or 2.580.0.

## Is CVE-2026-84649 being exploited?

There is no known exploitation of CVE-2026-84649 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84649 and fix it if it is affected.

What it is: CVE-2026-84649 is a high-severity vulnerability in Jenkins, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-84649 in the wild and no public exploit code.

Affected packages and fixed versions:
- jenkins (Bitnami): affected from 2.447.0; fixed in 2.568.3, 2.580.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84649/ (Markdown: https://insights.sbomify.com/CVE-2026-84649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84649
- OSV: https://osv.dev/vulnerability/CVE-2026-84649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84649/
Summaries are generated and may contain mistakes; the official description above is the record.
