CVE-2026-84650 Deserialization in Jenkins

High 8.8 Published Updated

Attackers can manipulate transient fields during deserialization in Jenkins, potentially leading to code execution or privilege escalation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-84650?

CVE-2026-84650 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Jenkins 2.579 and earlier, LTS 2.568.2 and earlier, transient fields cannot be excluded from deserialization, allowing attackers able to submit configuration updates to specify the values of transient fields that will be deserialized, the impact depending on how those fields are used.

Weakness: CWE-566, CWE-502

Which versions are affected by CVE-2026-84650?

1 open source package ship an affected version, including jenkins. It affects 1 product.

PackageAffectedFixed in
jenkins BitnamiAll versions2.568.3, 2.580.0

Products include Jenkins Jenkins.

How do I fix CVE-2026-84650?

Upgrade jenkins to a fixed version for your release line: 2.568.3 or 2.580.0.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-84650 being exploited?

There is no known exploitation of CVE-2026-84650 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as BIT-jenkins-2026-84650, GHSA-6q2p-xwgj-7xw4, MINI-82wg-pq29-4m3w, MINI-9xxh-2qw6-7wgx, MINI-cmgr-c3rq-jx94, MINI-ghr2-qxwq-fjg9 and 3 more.

Is CVE-2026-84650 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free