# CVE-2026-84654: Business logic in Jenkins

> Attackers can modify global public static fields via form data binding, potentially altering Jenkins instance behavior and escalating privileges.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 2 Sep 2026
- **Also known as:** BIT-jenkins-2026-84654, GHSA-jrvc-6cvv-qqx5, MINI-2pfg-4jqg-cjf2, MINI-5949-vcf9-jqrm, MINI-7f8v-jwqv-h4mw, MINI-929j-6hgm-36pw, MINI-977f-hg4p-76fv, MINI-p4xh-ppjp-xgv4, MINI-q59h-vrp9-rpgc

## What is CVE-2026-84654?

CVE-2026-84654 is a medium-severity vulnerability in Jenkins, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Stapler 2107.v8dfcb_e8ed317 and earlier, except 2088.2093.vd7c3e58008a_6, included in Jenkins 2.579 and earlier, LTS 2.568.2 and earlier, form data binding allows setting public static fields of the bound configuration object, allowing attackers who can submit configuration forms to modify public static fields of the configuration objects those forms are bound to, resulting in changes that apply globally to the Jenkins instance.

Weakness: CWE-472 (External Control of Assumed-Immutable Web Parameter)

## Which versions are affected by CVE-2026-84654?

1 open source package ship an affected version, including jenkins.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jenkins` | Bitnami | All versions | 2.568.3, 2.580.0 |

## How do I fix CVE-2026-84654?

Upgrade jenkins to a fixed version for your release line: 2.568.3 or 2.580.0.

## Is CVE-2026-84654 being exploited?

There is no known exploitation of CVE-2026-84654 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84654 and fix it if it is affected.

What it is: CVE-2026-84654 is a medium-severity vulnerability in Jenkins, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84654 in the wild and no public exploit code.

Affected packages and fixed versions:
- jenkins (Bitnami): affected all versions; fixed in 2.568.3, 2.580.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84654/ (Markdown: https://insights.sbomify.com/CVE-2026-84654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84654
- OSV: https://osv.dev/vulnerability/CVE-2026-84654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84654/
Summaries are generated and may contain mistakes; the official description above is the record.
