CVE-2026-8468 Unbounded buffer accumulation in multipart header parsing causes denial of service in plug
An unauthenticated remote attacker can cause denial of service by exhausting server memory through crafted multipart requests in the Plug library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-8468?
CVE-2026-8468 is a high-severity denial of service vulnerability in elixir-plug plug, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Allocation of Resources Without Limits or Throttling vulnerability in plug_project plug allows denial of service via unbounded buffer accumulation in multipart header parsing.
'Elixir.Plug.Conn':read_part_headers/2 in lib/plug/conn.ex does not obey its :length parameter. There is no upper bound on the size of the accumulated buffer. By contrast, the sibling function read_part_body has an explicit byte_size(acc) > length guard that stops accumulation once a limit is reached. No such guard exists in read_part_headers. An unauthenticated remote attacker can exhaust server memory by sending a crafted multipart/form-data request, causing a denial of service.
This issue affects plug from 1.4.0 before 1.15.4, 1.16.3, 1.17.1, 1.18.2, and 1.19.2.
Weakness: CWE-770
Which versions are affected by CVE-2026-8468?
11 open source packages ship an affected version, including plug.
| Package | Affected | Fixed in |
|---|---|---|
plug Hex | From 1.16.0 | 1.16.3 |
plug Hex | From 1.16.0 | 1.16.3 |
plug Hex | From 1.17.0 | 1.17.1 |
plug Hex | From 1.17.0 | 1.17.1 |
plug Hex | From 1.18.0 | 1.18.2 |
plug Hex | From 1.18.0 | 1.18.2 |
5 more packages
plug Hex | From 1.19.0 | 1.19.2 |
plug Hex | From 1.19.0 | 1.19.2 |
plug Hex | From 1.4.0 | 1.15.4, 1.16.3, 1.17.1, 1.18.2, 1.19.2 |
plug Hex | From 1.4.0 | 1.15.4 |
plug Hex | From 1.4.0 | 1.15.4 |
How do I fix CVE-2026-8468?
Upgrade plug to a fixed version for your release line: 1.16.3, 1.17.1, 1.18.2 or 1.19.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-8468 being exploited?
There is no known exploitation of CVE-2026-8468 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-8468, GHSA-468c-vq7p-gh64.