{"answers":{"affected":"11 open source packages ship an affected version, including plug.","exploited":"There is no known exploitation of CVE-2026-8468 in the wild and no public exploit code.","fix":"Upgrade plug to a fixed version for your release line: 1.16.3, 1.17.1, 1.18.2 or 1.19.2.","what":"CVE-2026-8468 is a high-severity denial of service vulnerability in elixir-plug plug, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-8468 and fix it if it is affected.\n\nWhat it is: CVE-2026-8468 is a high-severity denial of service vulnerability in elixir-plug plug, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-8468 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plug (Hex): affected from 1.16.0; fixed in 1.16.3\n- plug (Hex): affected from 1.16.0; fixed in 1.16.3\n- plug (Hex): affected from 1.17.0; fixed in 1.17.1\n- plug (Hex): affected from 1.17.0; fixed in 1.17.1\n- plug (Hex): affected from 1.18.0; fixed in 1.18.2\n- plug (Hex): affected from 1.18.0; fixed in 1.18.2\n- plug (Hex): affected from 1.19.0; fixed in 1.19.2\n- plug (Hex): affected from 1.19.0; fixed in 1.19.2\n- plug (Hex): affected from 1.4.0; fixed in 1.15.4, 1.16.3, 1.17.1, 1.18.2, 1.19.2\n- plug (Hex): affected from 1.4.0; fixed in 1.15.4\n- plug (Hex): affected from 1.4.0; fixed in 1.15.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-8468/ (Markdown: https://insights.sbomify.com/CVE-2026-8468/index.md)","id":"CVE-2026-8468","markdown":"https://insights.sbomify.com/CVE-2026-8468/index.md","name":"CVE-2026-8468","record":{"aliases":["EEF-CVE-2026-8468","GHSA-468c-vq7p-gh64"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir web library","requires_auth":"none","summary":"An unauthenticated remote attacker can cause denial of service by exhausting server memory through crafted multipart requests in the Plug library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Allocation of Resources Without Limits or Throttling vulnerability in plug_project plug allows denial of service via unbounded buffer accumulation in multipart header parsing.\n\n'Elixir.Plug.Conn':read_part_headers/2 in lib/plug/conn.ex does not obey its :length parameter. There is no upper bound on the size of the accumulated buffer. By contrast, the sibling function read_part_body has an explicit byte_size(acc) \u003e length guard that stops accumulation once a limit is reached. No such guard exists in read_part_headers. An unauthenticated remote attacker can exhaust server memory by sending a crafted multipart/form-data request, causing a denial of service.\n\nThis issue affects plug from 1.4.0 before 1.15.4, 1.16.3, 1.17.1, 1.18.2, and 1.19.2.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unbounded buffer accumulation in multipart header parsing causes denial of service in plug","id":"CVE-2026-8468","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":11,"n_references":9,"next":{"headline":"Unauthenticated denial-of-service via BEAM atom table exhaustion in phoenix_storybook","id":"CVE-2026-8469"},"packages":[{"ecosystem":"Hex","fixed":["1.16.3"],"introduced":["1.16.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.16.3"],"introduced":["1.16.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.17.1"],"introduced":["1.17.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.17.1"],"introduced":["1.17.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.18.2"],"introduced":["1.18.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.18.2"],"introduced":["1.18.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.19.2"],"introduced":["1.19.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.19.2"],"introduced":["1.19.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.15.4","1.16.3","1.17.1","1.18.2","1.19.2"],"introduced":["1.4.0","1.16.0","1.17.0","1.18.0","1.19.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"EEF-CVE-2026-8468"},{"ecosystem":"Hex","fixed":["1.15.4"],"introduced":["1.4.0"],"last_affected":[],"package":"plug","purl":null,"source":"GHSA-468c-vq7p-gh64"},{"ecosystem":"Hex","fixed":["1.15.4"],"introduced":["1.4.0"],"last_affected":[],"package":"plug","purl":"pkg:hex/plug","source":"GHSA-468c-vq7p-gh64"}],"prev":{"headline":"Unauthenticated remote code execution via HEEx template injection in phoenix_storybook playground","id":"CVE-2026-8467"},"products":["plug"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["elixir-plug"]},"summary":"An unauthenticated remote attacker can cause denial of service by exhausting server memory through crafted multipart requests in the Plug library.","url":"https://insights.sbomify.com/CVE-2026-8468/"}