# CVE-2026-8468: Unbounded buffer accumulation in multipart header parsing causes denial of service in plug

> An unauthenticated remote attacker can cause denial of service by exhausting server memory through crafted multipart requests in the Plug library.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 27 May 2026
- **Also known as:** EEF-CVE-2026-8468, GHSA-468c-vq7p-gh64

## What is CVE-2026-8468?

CVE-2026-8468 is a high-severity denial of service vulnerability in elixir-plug plug, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in plug_project plug allows denial of service via unbounded buffer accumulation in multipart header parsing.

'Elixir.Plug.Conn':read_part_headers/2 in lib/plug/conn.ex does not obey its :length parameter. There is no upper bound on the size of the accumulated buffer. By contrast, the sibling function read_part_body has an explicit byte_size(acc) > length guard that stops accumulation once a limit is reached. No such guard exists in read_part_headers. An unauthenticated remote attacker can exhaust server memory by sending a crafted multipart/form-data request, causing a denial of service.

This issue affects plug from 1.4.0 before 1.15.4, 1.16.3, 1.17.1, 1.18.2, and 1.19.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-8468?

11 open source packages ship an affected version, including plug.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plug` | Hex | From 1.16.0 | 1.16.3 |
| `plug` | Hex | From 1.16.0 | 1.16.3 |
| `plug` | Hex | From 1.17.0 | 1.17.1 |
| `plug` | Hex | From 1.17.0 | 1.17.1 |
| `plug` | Hex | From 1.18.0 | 1.18.2 |
| `plug` | Hex | From 1.18.0 | 1.18.2 |
| `plug` | Hex | From 1.19.0 | 1.19.2 |
| `plug` | Hex | From 1.19.0 | 1.19.2 |
| `plug` | Hex | From 1.4.0 | 1.15.4, 1.16.3, 1.17.1, 1.18.2, 1.19.2 |
| `plug` | Hex | From 1.4.0 | 1.15.4 |
| `plug` | Hex | From 1.4.0 | 1.15.4 |

## How do I fix CVE-2026-8468?

Upgrade plug to a fixed version for your release line: 1.16.3, 1.17.1, 1.18.2 or 1.19.2.

## Is CVE-2026-8468 being exploited?

There is no known exploitation of CVE-2026-8468 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8468 and fix it if it is affected.

What it is: CVE-2026-8468 is a high-severity denial of service vulnerability in elixir-plug plug, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-8468 in the wild and no public exploit code.

Affected packages and fixed versions:
- plug (Hex): affected from 1.16.0; fixed in 1.16.3
- plug (Hex): affected from 1.16.0; fixed in 1.16.3
- plug (Hex): affected from 1.17.0; fixed in 1.17.1
- plug (Hex): affected from 1.17.0; fixed in 1.17.1
- plug (Hex): affected from 1.18.0; fixed in 1.18.2
- plug (Hex): affected from 1.18.0; fixed in 1.18.2
- plug (Hex): affected from 1.19.0; fixed in 1.19.2
- plug (Hex): affected from 1.19.0; fixed in 1.19.2
- plug (Hex): affected from 1.4.0; fixed in 1.15.4, 1.16.3, 1.17.1, 1.18.2, 1.19.2
- plug (Hex): affected from 1.4.0; fixed in 1.15.4
- plug (Hex): affected from 1.4.0; fixed in 1.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8468/ (Markdown: https://insights.sbomify.com/CVE-2026-8468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8468
- OSV: https://osv.dev/vulnerability/CVE-2026-8468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8468/
Summaries are generated and may contain mistakes; the official description above is the record.
