CVE-2026-84805 Kimai 2.61.0 before 2.63.0 Authentication Bypass via API

Medium 5.3 Published Updated

Authenticated low-privilege users can modify admin-only work-contract preferences via the API due to missing permission checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-84805?

CVE-2026-84805 is a medium-severity missing authorization vulnerability in kimai, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Kimai versions from 2.61.0 before 2.63.0 fail to disable admin-only work-contract preferences for low-privilege users in the PATCH /api/users/{id}/preferences endpoint. Although the web interface gates these employment-contract fields behind the contract_other_profile admin permission, the WorkContractPreferenceSubscriber (introduced in 2.61.0) registers the preferences as enabled without a permission check, so an authenticated regular user can use the API to modify their own admin-only work-contract data. The issue is fixed in 2.63.0 by applying the same permission check to the API endpoint.

Weakness: CWE-862

Which versions are affected by CVE-2026-84805?

How do I fix CVE-2026-84805?

No fix has been published for CVE-2026-84805 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-84805 being exploited?

There is no known exploitation of CVE-2026-84805 in the wild and no public exploit code.

Sources

Also known as GHSA-5mpc-5cg2-g99r, GHSA-785m-wqjq-q2rm.

Is CVE-2026-84805 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free