# CVE-2026-84805: Kimai 2.61.0 before 2.63.0 Authentication Bypass via API

> Authenticated low-privilege users can modify admin-only work-contract preferences via the API due to missing permission checks.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Sep 2026
- **Updated:** 2 Sep 2026
- **Also known as:** GHSA-5mpc-5cg2-g99r, GHSA-785m-wqjq-q2rm

## What is CVE-2026-84805?

CVE-2026-84805 is a medium-severity missing authorization vulnerability in kimai, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kimai versions from 2.61.0 before 2.63.0 fail to disable admin-only work-contract preferences for low-privilege users in the PATCH /api/users/{id}/preferences endpoint. Although the web interface gates these employment-contract fields behind the contract_other_profile admin permission, the WorkContractPreferenceSubscriber (introduced in 2.61.0) registers the preferences as enabled without a permission check, so an authenticated regular user can use the API to modify their own admin-only work-contract data. The issue is fixed in 2.63.0 by applying the same permission check to the API endpoint.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-84805?


## How do I fix CVE-2026-84805?

No fix has been published for CVE-2026-84805 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-84805 being exploited?

There is no known exploitation of CVE-2026-84805 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84805 and fix it if it is affected.

What it is: CVE-2026-84805 is a medium-severity missing authorization vulnerability in kimai, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84805 in the wild and no public exploit code.

Affected product: kimai. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84805/ (Markdown: https://insights.sbomify.com/CVE-2026-84805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84805
- OSV: https://osv.dev/vulnerability/CVE-2026-84805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84805/
Summaries are generated and may contain mistakes; the official description above is the record.
