CVE-2026-84890 undici vulnerable to Denial of Service via unbounded decompression of compressed responses
A malicious server can crash Node.js applications using undici by sending a small compressed payload that expands to exhaust memory.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-84890?
CVE-2026-84890 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Weakness: CWE-770
Which versions are affected by CVE-2026-84890?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.15.0 | 7.29.1 |
undici npm | From 7.15.0 | 7.29.1 |
undici npm | From 8.0.0 | 8.10.2 |
undici npm | From 8.0.0 | 8.10.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-84890?
Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-84890 being exploited?
There is no known exploitation of CVE-2026-84890 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-CL40927, CLEANSTART-2026-LB53139, CLEANSTART-2026-ZU45548, DEBIAN-CVE-2026-84890, ECHO-eb33-91ee-8d11, GHSA-3xpg-4rpp-hhhm and 17 more.