# CVE-2026-84890: undici vulnerable to Denial of Service via unbounded decompression of compressed responses

> A malicious server can crash Node.js applications using undici by sending a small compressed payload that expands to exhaust memory.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-CL40927, CLEANSTART-2026-LB53139, CLEANSTART-2026-ZU45548, DEBIAN-CVE-2026-84890, ECHO-eb33-91ee-8d11, GHSA-3xpg-4rpp-hhhm, MINI-53h3-mj59-f8w6, MINI-56pc-8229-p5gp, MINI-73cj-fj66-pfp2, MINI-c67f-5v3w-gmj8, MINI-c85g-q56j-jcmj, MINI-gpr4-m574-h56m, MINI-h44q-2wgh-cjmr, MINI-hwhh-ch96-9xp5, MINI-q6pg-8ggw-w74f, MINI-qmxj-j453-hjj2, MINI-qvf6-gr89-mw23, MINI-vc8h-xv47-rfpm, MINI-vwgq-6mr3-f9rh, MINI-xfhp-7vcv-39vv, MINI-xj33-7xj9-vvfw, ROOT-APP-NPM-CVE-2026-84890, UBUNTU-CVE-2026-84890

## What is CVE-2026-84890?

CVE-2026-84890 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-84890?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.15.0 | 7.29.1 |
| `undici` | npm | From 7.15.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-84890?

Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.

## Is CVE-2026-84890 being exploited?

There is no known exploitation of CVE-2026-84890 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84890 and fix it if it is affected.

What it is: CVE-2026-84890 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84890 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.15.0; fixed in 7.29.1
- undici (npm): affected from 7.15.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84890/ (Markdown: https://insights.sbomify.com/CVE-2026-84890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84890
- OSV: https://osv.dev/vulnerability/CVE-2026-84890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84890/
Summaries are generated and may contain mistakes; the official description above is the record.
