# CVE-2026-84933: undici vulnerable to cross-user cookie disclosure via Set-Cookie caching in shared caches

> undici's shared cache leaks Set-Cookie headers to other users, allowing cookie disclosure and injection by untrusted servers.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-HS02762, CLEANSTART-2026-VO74481, CLEANSTART-2026-WF83239, CLEANSTART-2026-XL00241, CLSA-2026-1790756976, CLSA-2026-1790863452, CLSA-2026-1792867310, DEBIAN-CVE-2026-84933, ECHO-ac66-b5b7-0486, GHSA-2jfj-6hjv-fm6j, MINI-2h2h-7m7h-wwc3, MINI-4fqm-2xmm-3hf8, MINI-5h28-96fh-ff4f, MINI-6c79-ff3m-m225, MINI-8jxh-44xp-gfjc, MINI-fhxc-3qjp-9g9f, MINI-fvfx-cm9x-6r22, MINI-gmr3-6948-3fj2, MINI-hc49-whcr-xwh5, MINI-mc6x-ccrr-53xh, MINI-mv39-39jj-5f34, MINI-pp3m-7ph7-qfpv, MINI-q9g5-4j9w-9xhw, MINI-r396-w54g-2xm9, MINI-r3gj-5vhj-j3v8, MINI-vfhf-h83v-rq75, ROOT-APP-NPM-CVE-2026-84933, UBUNTU-CVE-2026-84933

## What is CVE-2026-84933?

CVE-2026-84933 is a medium-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's cache interceptor does not handle the Set-Cookie response header anywhere in its cache path, so it neither refuses to store nor strips that header. In shared cache mode, which is the default, an otherwise cacheable response that carries a Set-Cookie header, for example one marked with a public and max-age directive, is stored and then re-served to a later caller that matches the same cache key. As a result one caller's cookie is disclosed to a different caller, and an untrusted server can inject cookies into cached responses served to all subsequent callers. This violates the requirement that a shared cache must not store cookies. This affects undici versions from 7.0.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-84933?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-84933?

Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.

## Is CVE-2026-84933 being exploited?

There is no known exploitation of CVE-2026-84933 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84933 and fix it if it is affected.

What it is: CVE-2026-84933 is a medium-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84933 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84933/ (Markdown: https://insights.sbomify.com/CVE-2026-84933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84933
- OSV: https://osv.dev/vulnerability/CVE-2026-84933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84933/
Summaries are generated and may contain mistakes; the official description above is the record.
