CVE-2026-84947 undici vulnerable to response truncation via oversized chunked responses in the dump interceptor
An attacker can cause connection termination and misleading empty responses in undici by sending oversized chunked responses, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-84947?
CVE-2026-84947 is a low-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's dump interceptor reads and discards a response body up to a configurable maximum size. When a response declares a Content-Length that exceeds the maximum, the interceptor aborts cleanly, but when a response has no Content-Length and is chunked, the interceptor instead signals completion early once the accumulated size reaches the maximum, without pausing or aborting the request. Because the underlying parser keeps delivering body bytes, a second completion signal fires and trips an internal assertion, which aborts the request and tears down the connection. The application is left observing a misleading successful status with an empty or truncated body while the connection has actually been disconnected. This affects undici versions from 7.1.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Which versions are affected by CVE-2026-84947?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.1.0 | 7.29.1 |
undici npm | From 7.1.0 | 7.29.1 |
undici npm | From 8.0.0 | 8.10.2 |
undici npm | From 8.0.0 | 8.10.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-84947?
Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-84947 being exploited?
There is no known exploitation of CVE-2026-84947 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-MV66372, CLEANSTART-2026-PK15344, CLEANSTART-2026-QE41365, CLEANSTART-2026-WI13010, DEBIAN-CVE-2026-84947, ECHO-168b-8edd-7a87 and 19 more.