{"answers":{"affected":"4 open source packages ship an affected version, including undici. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-84947 in the wild and no public exploit code.","fix":"Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.","what":"CVE-2026-84947 is a low-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-84947 and fix it if it is affected.\n\nWhat it is: CVE-2026-84947 is a low-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-84947 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- undici (npm): affected from 7.1.0; fixed in 7.29.1\n- undici (npm): affected from 7.1.0; fixed in 7.29.1\n- undici (npm): affected from 8.0.0; fixed in 8.10.2\n- undici (npm): affected from 8.0.0; fixed in 8.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-84947/ (Markdown: https://insights.sbomify.com/CVE-2026-84947/index.md)","id":"CVE-2026-84947","markdown":"https://insights.sbomify.com/CVE-2026-84947/index.md","name":"CVE-2026-84947","record":{"aliases":["CLEANSTART-2026-MV66372","CLEANSTART-2026-PK15344","CLEANSTART-2026-QE41365","CLEANSTART-2026-WI13010","DEBIAN-CVE-2026-84947","ECHO-168b-8edd-7a87","GHSA-2gqq-gqf2-x968","MINI-2rvj-9rgf-ghf3","MINI-463f-8h3v-59hg","MINI-783r-qmcc-qwvv","MINI-7wm4-6f89-hvxp","MINI-8p9r-xvrr-x2vv","MINI-c5f5-pv76-j248","MINI-cxmj-63f2-f4fj","MINI-f8qp-hfqm-hmc3","MINI-fqh6-4vcr-78rm","MINI-g362-39xm-wwv7","MINI-g38w-q9p6-588g","MINI-q2q9-px9g-f5mr","MINI-w2jq-7f3f-5rqf","MINI-x32c-w7wj-f9c4","MINI-x5jc-p4xw-5c9x","MINI-xwrp-48h2-q87x","ROOT-APP-NPM-CVE-2026-84947","UBUNTU-CVE-2026-84947"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"An attacker can cause connection termination and misleading empty responses in undici by sending oversized chunked responses, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"undici","vendor":"nodejs"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"undici's dump interceptor reads and discards a response body up to a configurable maximum size. When a response declares a Content-Length that exceeds the maximum, the interceptor aborts cleanly, but when a response has no Content-Length and is chunked, the interceptor instead signals completion early once the accumulated size reaches the maximum, without pausing or aborting the request. Because the underlying parser keeps delivering body bytes, a second completion signal fires and trips an internal assertion, which aborts the request and tears down the connection. The application is left observing a misleading successful status with an empty or truncated body while the connection has actually been disconnected. This affects undici versions from 7.1.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"undici vulnerable to response truncation via oversized chunked responses in the dump interceptor","id":"CVE-2026-84947","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:undici","products":["nodejs:undici"],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"WP-Members Membership Plugin \u003c= 3.5.6 - Reflected Cross-Site Scripting","id":"CVE-2026-84960"},"packages":[{"ecosystem":"npm","fixed":["7.29.1"],"introduced":["7.1.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-2gqq-gqf2-x968"},{"ecosystem":"npm","fixed":["7.29.1"],"introduced":["7.1.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-2gqq-gqf2-x968"},{"ecosystem":"npm","fixed":["8.10.2"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-2gqq-gqf2-x968"},{"ecosystem":"npm","fixed":["8.10.2"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-2gqq-gqf2-x968"}],"prev":{"headline":"Stored Cross-Site Scripting via Vega Expression Function Bypass in OpenSearch Dashboards","id":"CVE-2026-84942"},"products":["undici"],"published":"2026-09-04","related":[{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake","id":"CVE-2026-109855","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unhandled error on excessive content-encodings","id":"CVE-2026-109869","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation","id":"CVE-2026-87018","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unrequested WebSocket subprotocol","id":"CVE-2026-19534","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via fragment count bypass","id":"CVE-2026-12151","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse","id":"CVE-2026-6734","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via cumulative fragment bypass","id":"CVE-2026-9675","kev_date_added":null,"published":"2026-06-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-04","vendors":["undici"]},"summary":"An attacker can cause connection termination and misleading empty responses in undici by sending oversized chunked responses, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-84947/"}