# CVE-2026-84947: undici vulnerable to response truncation via oversized chunked responses in the dump interceptor

> An attacker can cause connection termination and misleading empty responses in undici by sending oversized chunked responses, leading to denial of service.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-MV66372, CLEANSTART-2026-PK15344, CLEANSTART-2026-QE41365, CLEANSTART-2026-WI13010, DEBIAN-CVE-2026-84947, ECHO-168b-8edd-7a87, GHSA-2gqq-gqf2-x968, MINI-2rvj-9rgf-ghf3, MINI-463f-8h3v-59hg, MINI-783r-qmcc-qwvv, MINI-7wm4-6f89-hvxp, MINI-8p9r-xvrr-x2vv, MINI-c5f5-pv76-j248, MINI-cxmj-63f2-f4fj, MINI-f8qp-hfqm-hmc3, MINI-fqh6-4vcr-78rm, MINI-g362-39xm-wwv7, MINI-g38w-q9p6-588g, MINI-q2q9-px9g-f5mr, MINI-w2jq-7f3f-5rqf, MINI-x32c-w7wj-f9c4, MINI-x5jc-p4xw-5c9x, MINI-xwrp-48h2-q87x, ROOT-APP-NPM-CVE-2026-84947, UBUNTU-CVE-2026-84947

## What is CVE-2026-84947?

CVE-2026-84947 is a low-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's dump interceptor reads and discards a response body up to a configurable maximum size. When a response declares a Content-Length that exceeds the maximum, the interceptor aborts cleanly, but when a response has no Content-Length and is chunked, the interceptor instead signals completion early once the accumulated size reaches the maximum, without pausing or aborting the request. Because the underlying parser keeps delivering body bytes, a second completion signal fires and trips an internal assertion, which aborts the request and tears down the connection. The application is left observing a misleading successful status with an empty or truncated body while the connection has actually been disconnected. This affects undici versions from 7.1.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Weakness: CWE-248 (Uncaught Exception), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-84947?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.1.0 | 7.29.1 |
| `undici` | npm | From 7.1.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-84947?

Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.

## Is CVE-2026-84947 being exploited?

There is no known exploitation of CVE-2026-84947 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84947 and fix it if it is affected.

What it is: CVE-2026-84947 is a low-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84947 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.1.0; fixed in 7.29.1
- undici (npm): affected from 7.1.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84947/ (Markdown: https://insights.sbomify.com/CVE-2026-84947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84947
- OSV: https://osv.dev/vulnerability/CVE-2026-84947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84947/
Summaries are generated and may contain mistakes; the official description above is the record.
