# CVE-2026-84961: undici vulnerable to TLS certificate validation bypass via dropped connect options in BalancedPool

> Attackers can bypass custom TLS certificate validation in undici's BalancedPool by exploiting a JSON serialization bug that drops function-based security checks.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-NT71796, CLEANSTART-2026-XJ20290, CLEANSTART-2026-XX88554, DEBIAN-CVE-2026-84961, ECHO-e485-5b9d-e4bc, GHSA-w293-vg96-wgc3, MINI-3745-p356-hj7j, MINI-3rq5-gf7g-xcrj, MINI-5324-pm2g-gfx4, MINI-5hcc-w4mv-59rf, MINI-6565-86jg-7585, MINI-83gv-5532-53jg, MINI-979f-jcqh-wj88, MINI-9qx9-4jjf-mwr4, MINI-cq23-f5gq-f3pc, MINI-cr5g-p6gv-788x, MINI-g834-cp5f-fpv2, MINI-m2cv-cw49-7h86, MINI-w855-7phh-qcmx, ROOT-APP-NPM-CVE-2026-84961, UBUNTU-CVE-2026-84961

## What is CVE-2026-84961?

CVE-2026-84961 is a high-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's BalancedPool constructor passes its entire options object through an internal deep-clone that serializes and reparses the value as JSON. Because JSON cannot represent functions, any function-valued TLS option, such as a caller-supplied checkServerIdentity callback or a custom connector inside the connect option, is silently discarded before it reaches the TLS layer. As a result a peer whose certificate the application's custom checkServerIdentity was written to reject, but which still passes Node's default hostname and chain checks, is accepted when reached through BalancedPool. The Client, Pool, and Agent dispatchers are not affected because they extract the connect and tls options before cloning. This affects undici versions from 7.24.1 up to 7.29.1 and from 8.0.0 up to 8.10.2, and only when the application supplies a function-valued connect or tls option to BalancedPool. Users should upgrade to undici 7.29.1 or 8.10.2.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-84961?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.24.1 | 7.29.1 |
| `undici` | npm | From 7.24.1 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-84961?

Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.

## Is CVE-2026-84961 being exploited?

There is no known exploitation of CVE-2026-84961 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-84961 and fix it if it is affected.

What it is: CVE-2026-84961 is a high-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-84961 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.24.1; fixed in 7.29.1
- undici (npm): affected from 7.24.1; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-84961/ (Markdown: https://insights.sbomify.com/CVE-2026-84961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-84961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-84961
- OSV: https://osv.dev/vulnerability/CVE-2026-84961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-84961/
Summaries are generated and may contain mistakes; the official description above is the record.
