# CVE-2026-85008: undici vulnerable to caching and replay of unsafe HTTP method responses

> Attackers can cause state-changing requests to be served from stale cache, bypassing origin checks and modifying data integrity in undici HTTP client.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-AH89272, CLEANSTART-2026-BT10409, CLEANSTART-2026-OB41556, CLSA-2026-1790801425, DEBIAN-CVE-2026-85008, ECHO-db1d-df7f-29b4, GHSA-8436-99hf-9mmv, MINI-497j-8cf3-rx69, MINI-497p-3mm3-23jp, MINI-4r2q-8f8r-6c7v, MINI-557w-f78h-vvqw, MINI-7c9j-gf85-5228, MINI-7x82-82xf-95f9, MINI-f6g9-35wg-vhfm, MINI-hh4q-96x6-2f69, MINI-p2c2-grj3-mqph, MINI-q4mj-hc5p-47jc, MINI-qgmw-rxgp-3w96, MINI-r7x3-r5q9-h8f7, MINI-rc96-frw9-m8jx, MINI-rhq8-m9g6-c9h2, MINI-whgr-vh4r-p6w2, MINI-x6m5-rq4q-8h3x, ROOT-APP-NPM-CVE-2026-85008, UBUNTU-CVE-2026-85008

## What is CVE-2026-85008?

CVE-2026-85008 is a low-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's cache interceptor documents that only safe HTTP methods are cached, but its logic to skip caching is built by subtracting the configured methods from the set of safe methods, so an unsafe method such as POST, PUT, or DELETE is never placed in the skip list and instead falls through to the full cache-read path. The response-storage gate also lacked a method check, so a response to an unsafe request that is heuristically cacheable or carries an explicit Cache-Control directive is stored and later replayed from cache. Because response headers from a remote origin are untrusted, an origin can answer once with a cacheable status and then have the client's own subsequent state-changing requests to that path served from the stale cache entry without ever reaching the origin, an integrity failure that occurs under the interceptor's default configuration. This affects undici versions from 7.0.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-85008?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-85008?

Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.

## Is CVE-2026-85008 being exploited?

There is no known exploitation of CVE-2026-85008 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85008 and fix it if it is affected.

What it is: CVE-2026-85008 is a low-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85008 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85008/ (Markdown: https://insights.sbomify.com/CVE-2026-85008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85008
- OSV: https://osv.dev/vulnerability/CVE-2026-85008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85008/
Summaries are generated and may contain mistakes; the official description above is the record.
