CVE-2026-85014 undici vulnerable to Denial of Service via WebSocketStream unclean close
An untrusted server can crash a Node.js application using undici's WebSocketStream by abruptly closing the TCP connection, causing an unhandled rejection.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-85014?
CVE-2026-85014 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's experimental WebSocketStream client crashes the whole Node.js process when a remote peer closes the TCP connection without a WebSocket close handshake. On an unclean close the internal socket-close handler calls abort on the writable stream unconditionally and discards the returned promise, but per the WHATWG Streams standard aborting a locked writable returns a promise that rejects with a TypeError. Because the application holds a writer on that writable, which is the only way to write, the rejection is never observed and Node's default unhandled-rejection behavior terminates the process. An untrusted server can therefore crash a client with a single abrupt disconnect, with no authentication and no application mistake. This affects undici versions from 7.0.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
Which versions are affected by CVE-2026-85014?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.0.0 | 7.29.1 |
undici npm | From 7.0.0 | 7.29.1 |
undici npm | From 8.0.0 | 8.10.2 |
undici npm | From 8.0.0 | 8.10.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-85014?
Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-85014 being exploited?
There is no known exploitation of CVE-2026-85014 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-BJ62373, CLEANSTART-2026-BZ98480, CLEANSTART-2026-CA85404, DEBIAN-CVE-2026-85014, ECHO-a7c6-1ae0-8ec1, GHSA-rx4f-c7p8-82vq and 18 more.